Bug 819478 - transmission: transmission aborts during startup
transmission: transmission aborts during startup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 07:16 EDT by Mikolaj Izdebski
Modified: 2013-01-19 20:43 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-19 20:43:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-05-07 07:16:34 EDT
Description of problem:
transmission aborts at startup. This renders the package mostly unusable.

Version-Release number of selected component (if applicable):
transmission-2.50-2.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1. run /usr/bin/transmission-gtk 'magnet:?xt=urn:btih:This+Is+A+Dummy+Torrent+InfoHash'
2. press Accept button
  
Actual results:

GNU gdb (GDB) Fedora (7.3.50.20110722-13.fc16)
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/transmission-gtk...
warning: the debug information found in "/usr/lib/debug//usr/bin/transmission-gtk.debug" does not match "/usr/bin/transmission-gtk" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug/usr/bin/transmission-gtk.debug" does not match "/usr/bin/transmission-gtk" (CRC mismatch).

(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install transmission-gtk-2.42-2.fc16.x86_64
(gdb) r 'magnet:?xt=urn:btih:This+Is+A+Dummy+Torrent+InfoHash'
Starting program: /usr/bin/transmission-gtk 'magnet:?xt=urn:btih:This+Is+A+Dummy+Torrent+InfoHash'
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Gtk-Message: Failed to load module "pk-gtk-module"
Detaching after fork from child process 15024.
[New Thread 0x7ffff1780700 (LWP 15025)]
[New Thread 0x7ffff0f7f700 (LWP 15026)]
[New Thread 0x7fffebfff700 (LWP 15027)]
[New Thread 0x7fffeb7fe700 (LWP 15028)]
**
ERROR:open-dialog.c:285:gtr_torrent_options_dialog_new: code should not be reached

Program received signal SIGABRT, Aborted.
0x0000003c84436285 in raise () from /lib64/libc.so.6
(gdb) bt full
#0  0x0000003c84436285 in raise () from /lib64/libc.so.6
No symbol table info available.
#1  0x0000003c84437b9b in abort () from /lib64/libc.so.6
No symbol table info available.
#2  0x00000034cbe688dd in g_assertion_message () from /lib64/libglib-2.0.so.0
No symbol table info available.
#3  0x00000000004342c6 in gtr_torrent_options_dialog_new ()
No symbol table info available.
#4  0x000000000042f42b in ?? ()
No symbol table info available.
#5  0x00000034cc60ea44 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#6  0x00000034cc620d37 in ?? () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#7  0x00000034cc62a161 in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#8  0x00000034cc62a302 in g_signal_emit () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#9  0x0000000000439235 in ?? ()
No symbol table info available.
#10 0x000000000043938a in ?? ()
No symbol table info available.
#11 0x000000000043a444 in gtr_core_add_files ()
No symbol table info available.
#12 0x000000000042eb55 in ?? ()
No symbol table info available.
#13 0x0000003c87005d64 in ffi_call_unix64 () from /usr/lib64/libffi.so.5
No symbol table info available.
#14 0x0000003c87005785 in ffi_call () from /usr/lib64/libffi.so.5
No symbol table info available.
#15 0x00000034cc60ef6b in g_cclosure_marshal_generic () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#16 0x00000034cc60ea44 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#17 0x00000034cc620d37 in ?? () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#18 0x00000034cc62a161 in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#19 0x00000034cc62a302 in g_signal_emit () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#20 0x00000034cce958bb in ?? () from /lib64/libgio-2.0.so.0
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#21 0x00000034cce95ab8 in g_application_run () from /lib64/libgio-2.0.so.0
No symbol table info available.
#22 0x0000000000420dc7 in main ()
No symbol table info available.
Comment 1 Sergio 2012-05-29 13:53:44 EDT
I'm using 2.50-2.fc17 and I also get this error when I try to open a .torrent file

ERROR:open-dialog.c:284:gtr_torrent_options_dialog_new: code should not be reached
Comment 2 Sergio 2012-05-31 13:34:39 EDT
I started using transmission-cli because of this issue, now I opened transmission-gtk and it has (good!) the torrent I was seeding from the command-line.
I haven't yet tried again adding another torrent from the GUI.

Note You need to log in before you can comment on or make changes to this bug.