Bug 819510 - init script fails to stop gluster-nfsd and glutershd.
init script fails to stop gluster-nfsd and glutershd.
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 09:06 EDT by Etsuji Nakai
Modified: 2013-12-18 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 23:47:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Etsuji Nakai 2012-05-07 09:06:52 EDT
Description of problem:

The init script for glusterd fails to stop gluster-nfsd and glutershd.

Version-Release number of selected component (if applicable):

# rpm -qa | grep glusterfs
glusterfs-3.3.0qa38-1.el6.x86_64
glusterfs-fuse-3.3.0qa38-1.el6.x86_64
glusterfs-server-3.3.0qa38-1.el6.x86_64
glusterfs-geo-replication-3.3.0qa38-1.el6.x86_64
glusterfs-rdma-3.3.0qa38-1.el6.x86_64

How reproducible:

[root@rhs20b2-01 ~]# service glusterd stop
Stopping glusterd:                                         [  OK  ]

[root@rhs20b2-01 ~]# ps -ef | grep gluste[r]
root      4227     1  0 12:47 ?        00:00:00 /usr/sbin/glusterfs -s localhost --volfile-id gluster/nfs -p /var/lib/glusterd/nfs/run/nfs.pid -l /var/log/glusterfs/nfs.log -S /tmp/9ce16084ada949ea8c9a2c6489d28fa7.socket
root      4233     1  0 12:47 ?        00:00:00 /usr/sbin/glusterfs -s localhost --volfile-id gluster/glustershd -p /var/lib/glusterd/glustershd/run/glustershd.pid -l /var/log/glusterfs/glustershd.log -S /tmp/4d96ff6dd7024a5e6d0a214eb58b4640.socket --xlator-option *replicate*.node-uuid=5a6b4e6f-3fd4-4a36-9c6c-07b4014f386c

After stopping the glusterd service, gluster-nfs and glustershd are still running.
Comment 1 Amar Tumballi 2012-05-10 02:27:25 EDT
the plan is to work on bug 815483 to not stop any other process other than 'glusterd' when /etc/init.d/glusterd stop is issued.
Comment 2 Amar Tumballi 2012-05-18 23:47:16 EDT
after http://review.gluster.com/2919 going in, only 'glusterd' process will be stopped in /etc/init.d/glusterd stop is done. Treating this as not a bug.

Note You need to log in before you can comment on or make changes to this bug.