Bug 819516 - ovirt-engine-backend: GUI Stuck when attempting to attach multiple virtual disks to VM.
ovirt-engine-backend: GUI Stuck when attempting to attach multiple virtual di...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity urgent
: ---
: 3.1.0
Assigned To: Daniel Erez
Leonid Natapov
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 09:15 EDT by Omri Hochman
Modified: 2016-02-10 11:43 EST (History)
6 users (show)

See Also:
Fixed In Version: SI9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:10:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omri Hochman 2012-05-07 09:15:37 EDT
ovirt-engine-backend: GUI Stuck when attempting to attach multiple virtual disks to VM. 

scenario:
**********
1) Create VM .
2) Create multiple virtual disks.
3) Attempt to attach more than 1 virtual disk to the VM. 

Results:
*********
1) GUI/Browser immediately Stuck when selecting multiple disks and attempting to attach to the VM. 
2) After restart of the browser and logged in to rhevm , the GUI got stuck each time attempted to view : the 'specific VM --> Virtual Disk (sub-tab)'.


engine.log:  - (GUI stuck first time when attaching multiple HD's)
************
2012-05-07 16:00:00,001 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-20) Checking autorecoverable hosts
2012-05-07 16:00:00,006 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-20) Checking autorecoverable hosts done
2012-05-07 16:00:00,007 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-20) Checking autorecoverable storage domains
2012-05-07 16:00:00,009 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-20) Checking autorecoverable storage domains done
2012-05-07 16:00:08,617 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (ajp--0.0.0.0-8009-2) calling GetConfigurationValueQuery (MaxDiskSize) with null version, using default general for version
2012-05-07 16:00:08,841 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (ajp--0.0.0.0-8009-6) calling GetConfigurationValueQuery (SANWipeAfterDelete) with null version, using default general for version
2012-05-07 16:00:14,480 INFO  [org.ovirt.engine.core.bll.MultipleActionsRunner] (pool-10-thread-50) Start time: 5/7/12 4:00 PM. Start running CanDoAction for command number 1/2 (Command type: AttachDiskToVm)
2012-05-07 16:00:14,483 INFO  [org.ovirt.engine.core.bll.MultipleActionsRunner] (pool-10-thread-49) Start time: 5/7/12 4:00 PM. Start running CanDoAction for command number 2/2 (Command type: AttachDiskToVm)
2012-05-07 16:00:14,601 INFO  [org.ovirt.engine.core.bll.MultipleActionsRunner] (pool-10-thread-49) End time: 5/7/12 4:00 PM. Finish handling CanDoAction for command number 2/2 (Command type: AttachDiskToVm)
2012-05-07 16:00:14,612 INFO  [org.ovirt.engine.core.bll.MultipleActionsRunner] (pool-10-thread-50) End time: 5/7/12 4:00 PM. Finish handling CanDoAction for command number 1/2 (Command type: AttachDiskToVm)
2012-05-07 16:00:14,614 INFO  [org.ovirt.engine.core.bll.AttachDiskToVmCommand] (pool-10-thread-50) [75b05a53] Running command: AttachDiskToVmCommand internal: false. Entities affected :  ID: 3acf3ef8-6454-4f07-89bd-65a67f36b860 Type: VM,  ID: d52e377c-d1ee-477d-a41e-a690792590e5 Type: Disk
2012-05-07 16:00:14,700 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-10-thread-50) [75b05a53] No string for UNASSIGNED type. Use default Log
2012-05-07 16:00:14,717 INFO  [org.ovirt.engine.core.bll.AttachDiskToVmCommand] (pool-10-thread-50) [531ee090] Running command: AttachDiskToVmCommand internal: false. Entities affected :  ID: 3acf3ef8-6454-4f07-89bd-65a67f36b860 Type: VM,  ID: 69dbac14-5b6b-4c01-973f-eeab052c6ec0 Type: Disk
2012-05-07 16:00:14,759 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-10-thread-50) [531ee090] No string for UNASSIGNED type. Use default Log


engine.log: ( GUI Stuck when attempting to [query] view virtual-disk sub tab)
**************
2012-05-07 15:57:36,189 WARN  [org.ovirt.engine.core.dal.dbbroker.generic.DBConfigUtils] (http--0.0.0.0-8080-6) Adding new value to configuration cache.
2012-05-07 15:57:36,204 WARN  [org.ovirt.engine.core.dal.dbbroker.generic.DBConfigUtils] (http--0.0.0.0-8080-6) Didnt find the value of DBI18NPrefix in DB for version general - using default:
Comment 1 Daniel Erez 2012-05-09 12:04:49 EDT
commit ef2d44c028c96a1d6de3e3fe10abe6074a2472e5
Comment 2 Leonid Natapov 2012-07-09 09:11:37 EDT
si9. fixed. was unable to reproduce.

Note You need to log in before you can comment on or make changes to this bug.