Bug 819524 - sane-backends-libs dependency issue in FC17
sane-backends-libs dependency issue in FC17
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 09:25 EDT by Chris Snell
Modified: 2014-01-21 18:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 11:13:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Snell 2012-05-07 09:25:42 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Performed preupgrade from Fedora 16 to Fedora 17 (left to finish overnight)
2. In the morning, attempted a yum update
  
Actual results:

Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Importing GPG key 0x1ACA3465:
 Userid     : "Fedora (17) <fedora@fedoraproject.org>"
 Fingerprint: cac4 3fb7 74a4 a673 d81c 5de7 50e9 4c99 1aca 3465
 Package    : fedora-release-17-0.9.noarch (@anaconda-0)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Running Transaction Check
ERROR with transaction check vs depsolve:
sane-backends-libs(x86-32) = 1.0.22-9.fc17 is needed by (installed) sane-backends-drivers-cameras-1.0.22-9.fc17.i686
sane-backends = 1.0.22-9.fc17 is needed by (installed) sane-backends-drivers-cameras-1.0.22-9.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
sane-backends-drivers-cameras-1.0.22-9.fc17.i686 has missing requires of sane-backends = ('0', '1.0.22', '9.fc17')
sane-backends-libs-1.0.22-10.fc15.x86_64 is a duplicate with sane-backends-libs-1.0.22-9.fc17.i686
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-05-07.07-45.Ur0cSy.yumtx

Expected results:

Successful yum update.

Additional info:

$ cat /etc/redhat-release 
Fedora release 17 (Beefy Miracle)
$ uname -a
Linux lion 3.3.4-1.fc16.x86_64 #1 SMP Fri Apr 27 20:12:28 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
$ sudo yum list installed | grep sane-backends-libs
sane-backends-libs.i686             1.0.22-9.fc17                    @anaconda-0
sane-backends-libs.x86_64           1.0.22-10.fc15                   @updates/15
Comment 1 James Antill 2012-05-07 11:13:20 EDT
As it says, these are preexisting bugs in the rpmdb.
Comment 2 Chris Snell 2012-05-07 15:20:31 EDT
This machine went from a clean install of FC 15, to a yum -y update, to a preupgrade to FC16, to a yum -y update, to a preupgrade of FC17.  No other software was installed, and no customization was done during the install.  This is a perfectly logical upgrade path.  Taking the defaults the entire way shouldn't produce an error, but this did.

Note You need to log in before you can comment on or make changes to this bug.