Bug 819557 - forum comments are accepted but ack page return times out.
forum comments are accepted but ack page return times out.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 10:21 EDT by Mark Lamourine
Modified: 2015-05-14 21:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 13:22:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Lamourine 2012-05-07 10:21:38 EDT
Description of problem:

When submitting a comment to a forum thread, after hitting the "save" button, the server does not return a response page within the browser timeout period.

Tested with both Google Chrome and Firefox, both from inside the RH office network.


Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1.Add a comment to the thread below:

https://openshift.redhat.com/community/forums/openshift/build-your-own-paas-dynamic-dns-configuration

2.Submit using the "save" button.

3. Wait for response timeout.
  
Actual results:

Page reply times out in browser


Expected results:

Return to forum thread page with new comment in line and ack of acceptance of the new comment.


Additional info:

A user also reported getting emails from this thread without having ever subscribed or commented and attempts to follow the "unsubscribe" link lead to 'access denied"
Comment 1 Clayton Coleman 2012-05-08 12:54:51 EDT
Looks like this is caused by a huge notification queue.  Anderson is investigating the perf tuning for the mysql db (which is in stock state which is not up to running the community) and I am investigating turning of immediate sending (which should speed it back up again).
Comment 2 Clayton Coleman 2012-05-09 01:04:00 EDT
This will be fixed via configuration on drupal instances in stage and production.
Comment 3 Clayton Coleman 2012-05-09 16:31:50 EDT
Anderson is pushing config to production.  I'm testing staged email notifications, but we won't attempt to shift to it until monday.
Comment 4 Clayton Coleman 2012-05-10 11:48:29 EDT
We've fixed the performance DB issue that was causing timeouts.
Comment 5 Yujie Zhang 2012-05-11 04:42:53 EDT
Verify this bug on stage, the time out problem has been fixed now.

Note You need to log in before you can comment on or make changes to this bug.