Bug 819586 - inadyn.service expects pid file at /run/inadyn.pid
inadyn.service expects pid file at /run/inadyn.pid
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: inadyn-mt (Show other bugs)
17
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 11:56 EDT by Daniel Wang
Modified: 2012-05-26 03:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 03:27:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Wang 2012-05-07 11:56:28 EDT
Description of problem:
/usr/lib/systemd/system/inadyn.service expects a pid file at /run/inadyn.pid , but inadyn-mt does not create it. The result is that "systemctl start inadyn.service" times out since systemd is waiting for a pid file that will never get created. We should either patch the service file so that no pid file is expected or wrap up inadyn with a script that determines the pid and writes it to /run/inadyn.pid

Version-Release number of selected component (if applicable):
inadyn-mt-2.24.36-2.fc17.i686

How reproducible:
always

Steps to Reproduce:
1. install inadyn-mt
2. configure /etc/inadyn-mt.conf
3. systemctl service start inadyn.service 

  
Actual results:
"Job failed. See system journal and 'systemctl status' for details."
"inadyn.service - Inadyn-mt, register an IP Address to a dynamic DNS provider
	  Loaded: loaded (/usr/lib/systemd/system/inadyn.service; enabled)
	  Active: failed (Result: timeout) since Mon, 07 May 2012 08:32:29 -0700; 6s ago
	 Process: 19761 ExecStart=/usr/sbin/inadyn (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/inadyn.service

May 07 08:30:59 xxxxxxx INADYN[19762]: Mon May  7 08:30:59 2012: W:INADYN: ...."


Expected results:
(quiet success)

Additional info:
Commenting out the PIDFile line in inadyn.service seems to work okay.
Comment 1 Fedora Update System 2012-05-08 14:50:10 EDT
inadyn-mt-2.24.36-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/inadyn-mt-2.24.36-3.fc17
Comment 2 Fedora Update System 2012-05-09 12:11:16 EDT
Package inadyn-mt-2.24.36-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing inadyn-mt-2.24.36-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7528/inadyn-mt-2.24.36-3.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-05-26 03:27:09 EDT
inadyn-mt-2.24.36-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.