Bug 819613 - Wrong Dependency Prevents eclipse install
Wrong Dependency Prevents eclipse install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 13:55 EDT by Amir Hedayaty
Modified: 2012-06-06 13:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 13:13:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amir Hedayaty 2012-05-07 13:55:32 EDT
Description of problem:

java-1.7.0-openjdk-devel.x86_64 depends on java-1.7.0-openjdk.i686 1:1.7.0.3-2.1.fc17.1

I guess no more description is needed. java is a binary package and can not
coexist with 64bit version. It does not allow that to be installed as a result preventing eclipse install.

Here is the yum output:

yum install java-1.7.0-openjdk-devel.x86_64
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package java-1.7.0-openjdk-devel.x86_64 1:1.7.0.3-2.1.fc17.1 will be installed
--> Processing Dependency: java-1.7.0-openjdk = 1:1.7.0.3-2.1.fc17.1 for package: 1:java-1.7.0-openjdk-devel-1.7.0.3-2.1.fc17.1.x86_64
--> Running transaction check
---> Package java-1.7.0-openjdk.i686 1:1.7.0.3-2.1.fc17.1 will be installed
--> Processing Dependency: liblcms2.so.2 for package: 1:java-1.7.0-openjdk-1.7.0.3-2.1.fc17.1.i686
--> Processing Dependency: libgif.so.4 for package: 1:java-1.7.0-openjdk-1.7.0.3-2.1.fc17.1.i686
--> Running transaction check
---> Package giflib.i686 0:4.1.6-5.fc17 will be installed
---> Package lcms2.i686 0:2.3-2.fc17 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: 1:java-1.7.0-openjdk-1.7.0.3-2.1.fc17.1.i686 != 1:java-1.7.0-openjdk-1.7.0.3-2.1.fc17.6.x86_64
Comment 1 Deepak Bhole 2012-05-07 15:28:10 EDT
Thanks for reporting this. I have opened a rel-eng bug:

https://fedorahosted.org/rel-eng/ticket/5181
Comment 2 Omair Majid 2012-05-08 11:11:31 EDT
I am not sure if this is limited to java:

# yum install libxcb libxcb-devel
Package matching libxcb-1.8-2.fc17.x86_64 already installed. Checking for update.
Resolving Dependencies
--> Running transaction check
---> Package libxcb-devel.x86_64 0:1.8-2.fc17 will be installed
--> Processing Dependency: libxcb = 1.8-2.fc17 for package: libxcb-devel-1.8-2.fc17.x86_64
--> Running transaction check
---> Package libxcb.i686 0:1.8-2.fc17 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: libxcb-1.8-2.fc17.i686
--> Processing Dependency: libXau.so.6 for package: libxcb-1.8-2.fc17.i686
--> Running transaction check
---> Package glibc.i686 0:2.15-35.fc17 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.15-35.fc17.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.15-35.fc17.i686
---> Package libXau.i686 0:1.0.6-3.fc17 will be installed
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.13.4-2.fc17 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: libxcb-1.8-2.fc17.i686 != libxcb-1.8.1-1.fc17.x86_64
Comment 3 Omair Majid 2012-05-08 21:20:37 EDT
A yum distro-sync worked for me. I can install java-1.7.0-openjdk-devel too. Can you reproduce the problem (on another machine or after a fresh install, or after a yum distro-sync)?
Comment 4 Amir Hedayaty 2012-06-06 13:13:30 EDT
Thanks. It seems to be fixed.

Note You need to log in before you can comment on or make changes to this bug.