Bug 81966 - xmag crashes on certain mouse behaviour
xmag crashes on certain mouse behaviour
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-15 16:05 EST by Trevor Spiteri
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-18 12:17:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trevor Spiteri 2003-01-15 16:05:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start xmag and get the xmag window.
2. Left-click in the window. A bar pops up in the window showing the pixel
location and color.
3. Drag the mouse pointer (without releasing the button) onto this popup bar and
release the button.
    

Actual Results:  Xmag crashes with a message:
Segmentation fault

Additional info:
Comment 1 Mike A. Harris 2003-01-15 18:36:25 EST
Reproduced.  Here's a backtrace...


Program received signal SIGSEGV, Segmentation fault.
0x400c4030 in XtPopdown () from /usr/X11R6/lib/libXt.so.6
(gdb) bt
#0  0x400c4030 in XtPopdown () from /usr/X11R6/lib/libXt.so.6
#1  0x0804a1b6 in ceil ()
#2  0x400dbaea in _XtMatchAtom () from /usr/X11R6/lib/libXt.so.6
#3  0x400dc028 in _XtMatchAtom () from /usr/X11R6/lib/libXt.so.6
#4  0x400dc623 in _XtTranslateEvent () from /usr/X11R6/lib/libXt.so.6
#5  0x400b4864 in XtDispatchEventToWidget () from /usr/X11R6/lib/libXt.so.6
#6  0x400b5015 in _XtOnGrabList () from /usr/X11R6/lib/libXt.so.6
#7  0x400b5423 in _XtOnGrabList () from /usr/X11R6/lib/libXt.so.6
#8  0x400b555f in XtDispatchEvent () from /usr/X11R6/lib/libXt.so.6
#9  0x400b5ab4 in XtAppMainLoop () from /usr/X11R6/lib/libXt.so.6
#10 0x0804bae9 in ceil ()
#11 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6

Looks like a bug in libXt
Comment 2 Mike A. Harris 2003-01-18 06:26:26 EST
Problem reported to XFree86.org on Saturday Jan 18, 2003.  Awaiting
response, and will update this report when new information is available.
Comment 3 Mike A. Harris 2003-01-18 12:17:48 EST
Bug fixed.  Will be in next RPM package release.

Note You need to log in before you can comment on or make changes to this bug.