Bug 819729 - Unclear error message when connect vCenter server
Unclear error message when connect vCenter server
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Libvirt Maintainers
:
: 886832 947398 (view as bug list)
Depends On:
Blocks: 947398
  Show dependency treegraph
 
Reported: 2012-05-08 01:21 EDT by lei wang
Modified: 2016-04-26 10:23 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 947398 (view as bug list)
Environment:
Last Closed: 2016-03-23 18:00:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lei wang 2012-05-08 01:21:58 EDT
Description of problem:
Unclear error message when connect vCenter server with virsh command "virsh -c esx://xxx.xxx.xxx.xxx/?no_verify=1", the error "internal error Could not find ComputeResource with name '(null)'" will be shown.

Version-Release number of selected component (if applicable):
# rpm -qa |grep libvirt
libvirt-client-0.9.10-16.el6.x86_64
libvirt-debuginfo-0.9.10-14.el6.x86_64
libvirt-0.9.10-16.el6.x86_64
libvirt-python-0.9.10-16.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.When connect ESXi server,pass the url of the Virtualcenter.

eg:virsh -c esx://<VirtualcenterIP>/?no_verify=1
Enter username for ip [root]:
Enter administrator's password for ip: 

  
Actual results:
[root@test ~]# virsh -c esx://10.66.6.123/?no_verify=1
Enter username for 10.66.6.123 [root]: administrator
Enter administrator's password for 10.66.6.123: 
error: internal error Could not find ComputeResource with name '(null)'
error: failed to connect to the hypervisor
[root@test ~]# 

Expected results:
There should be clear error messages given like:the host is neither an ESX 3.5, 4.x nor 5.x host

eg:# virsh -c esx://10.66.6.48/?no_verify=1
Enter username for 10.66.6.48 [root]: administrator
Enter administrator's password for 10.66.6.48:
error: internal error 10.66.6.48 is neither an ESX 3.5, 4.x nor 5.x host
error: failed to connect to the hypervisor

Additional info:
Comment 3 Gunannan Ren 2012-07-19 03:25:09 EDT
The problem couldn't be reproduced upstream, probably has been fixed.
but I couldn't find the corresponding patch.

The error message is expected.
#virsh -c esx://10.66.6.123/?no_verify=1

error: internal error 10.66.6.123 is neither an ESX 3.5, 4.x nor 5.x host
error: failed to connect to the hypervisor
Comment 6 zhe peng 2012-07-24 04:05:19 EDT
verify with:
libvirt-0.9.13-3.el6.x86_64

step:
make sure 10.66.6.123 is vCenter server
1 #virsh -c esx://10.66.6.123/?no_verify=1
input correct user&password

error: internal error 10.66.6.123 is neither an ESX 3.5, 4.x nor 5.x host
error: failed to connect to the hypervisor

the error msg. is expected. move to verified.
Comment 10 Jiri Denemark 2013-01-28 07:48:33 EST
According to comment 7, this bug is apparently not fixed in current libvirt builds. Moving back to ASSIGNED and to the next release.
Comment 11 Jiri Denemark 2013-01-28 07:49:22 EST
*** Bug 886832 has been marked as a duplicate of this bug. ***
Comment 12 Dave Allan 2013-01-28 12:37:57 EST
Thanks, Jiri.
Comment 14 Dave Allan 2013-05-13 10:25:36 EDT
*** Bug 947398 has been marked as a duplicate of this bug. ***
Comment 15 Cole Robinson 2016-03-23 18:00:26 EDT
Bug is old and I have no setup to test if this is still valid. Closing as DEFERRED but if anyone can still reproduce with a modern libvirt please reopen

Note You need to log in before you can comment on or make changes to this bug.