Bug 819749 - Please enable PostgreSQL support in Postfix RPM by default
Please enable PostgreSQL support in Postfix RPM by default
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: postfix (Show other bugs)
6.2
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 03:01 EDT by Zhang Huangbin
Modified: 2016-07-27 18:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 18:16:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhang Huangbin 2012-05-08 03:01:30 EDT
Dear developers,

Please consider enabling PostgreSQL support in Postfix RPM by default. We now have iRedMail[1] (a free, open source mail server solution) for building a full-featured, Postfix + PostgreSQL mail server solution on RHEL 6.x, but it requires rebuild Postfix RPM for pgsql support. Please, please seriously consider enabling PostgreSQL support in Postfix RPM by default. Thanks.

[1] iRedMail: http://www.iredmail.org/
Comment 2 RHEL Product and Program Management 2012-09-07 01:30:02 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2013-10-13 20:40:36 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Jaroslav Škarvada 2014-12-01 11:44:30 EST
I am not supporting this request, because there will be very probably people complaining about postfix bringing-in new deps, namely postgresql-libs and its deps (e.g. kerberos), which is something they don't expect during the RHEL-6 lifecycle. This is not comparable to our addition of MySQL support to RHEL-5, because this time the PostgreSQL support is not by default enabled in Fedora and postfix package would depend on another SQL library.

Reporter, if it is important for your business, please escalate this through the support channel.
Comment 7 Zhang Huangbin 2014-12-02 04:37:56 EST
(In reply to Jaroslav Škarvada from comment #6)
> I am not supporting this request, because there will be very probably people
> complaining about postfix bringing-in new deps, namely postgresql-libs and
> its deps (e.g. kerberos), which is something they don't expect during the
> RHEL-6 lifecycle. This is not comparable to our addition of MySQL support to
> RHEL-5, because this time the PostgreSQL support is not by default enabled
> in Fedora and postfix package would depend on another SQL library.

I don't agree. Bringing in new deps doesn't mean bringing in new troubles.

> Reporter, if it is important for your business, please escalate this through
> the support channel.

I thought this is the support channel to help improve RHEL.

According to your description, i don't think you guys really care about this channel, especially issues reported by users who didn't buy products. Check the report date, it's 2012. Whatever, let it be closed in 2020, just like my other reports here.
Comment 8 Jaroslav Škarvada 2014-12-02 05:55:38 EST
(In reply to Zhang Huangbin from comment #7)

Bugzilla is not support tool. Get support on:
http://www.redhat.com/support
Comment 10 Jaroslav Škarvada 2016-07-27 18:16:31 EDT
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.

Note You need to log in before you can comment on or make changes to this bug.