Bug 819818 - [ALL LANG] [RHSM CLI] Unlocalized string 'Service level xx is not available ... ' in register module.
[ALL LANG] [RHSM CLI] Unlocalized string 'Service level xx is not available ....
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: Translation
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-05-08 05:55 EDT by Lijun Li
Modified: 2015-05-14 12:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-29 15:05:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unlocalized string 'Service level xx is not available ... ' in register module (25.27 KB, image/png)
2012-05-08 05:57 EDT, Lijun Li
no flags Details

  None (edit)
Description Lijun Li 2012-05-08 05:55:55 EDT
Description of problem:
Unlocalized string 'Service level xx is not available ... ' in register module.

Version-Release number of selected component (if applicable):
subscription-manager-0.99.16-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install latest RHEL6.3 build (Snapshot-2).

2. Run command from terminal.
(Register with --servicelevel)
$ sudo subscription-manager register --username=USERNAME --password=PASSWORD --servicelevel=SERVICE_LEVEL

Actual results:
Unlocalized string 'Service level xx is not available ... ' in register module.

Expected results:
It should be localized.

Additional info:
Comment 1 Lijun Li 2012-05-08 05:57:13 EDT
Created attachment 582942 [details]
Unlocalized string 'Service level xx is not available ... ' in register module
Comment 3 Michael Stead 2012-05-08 13:23:19 EDT
Changing product and component to candlepin since the string originates from candlepin.

Verified that an attempt is made to translate with i18n, but the translation does not appear to exist.
Comment 4 Ankit Patel 2012-05-10 01:45:49 EDT
I can see from: https://translate.zanata.org/zanata/project/view/candlepin that the message is well translated in all the languages. wondering why it doesn't appear in actual UI.
Comment 6 Bryan Kearney 2012-12-20 11:55:06 EST
This is translated in Candlepin as of 0.7.23
Comment 7 John Sefler 2013-11-22 17:43:28 EST
Verifying Version...
[root@jsefler-7 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.33-1
subscription-manager: 1.10.7-1.el7
python-rhsm: 1.10.6-1.el7


[root@jsefler-7 ~]# subscription-manager register --username testuser1 --org admin --auto-attach --force --servicelevel=TESTING
The system with UUID 05f941a7-f6a9-4616-95bf-1f992fda973a has been unregistered
Password: 
The system has been registered with ID: 6ddfbc6b-aed9-4b15-909b-867366b3b041 
Service level 'TESTING' is not available to units of organization admin.


[root@jsefler-7 ~]# LANG=zh_CN.UTF8 subscription-manager register --username testuser1 --org admin --auto-attach --force --servicelevel=TESTING
UUID 为 6ddfbc6b-aed9-4b15-909b-867366b3b041 的系统已经被取消注册
密码:
已经使用 ID 5f1673c4-76bc-4c82-a8f2-e93272b1823b 注册该系统
机构 admin 的单元无法使用服务等级 'TESTING' 。


[root@jsefler-7 ~]# LANG=fr_FR.UTF8 subscription-manager register --username testuser1 --org admin --auto-attach --force --servicelevel=TESTING
Le système avec l'UUID5f1673c4-76bc-4c82-a8f2-e93272b1823b a été désenregistré
Mot de passe : 
Le système a été enregistré avec l'ID : b5c85c46-223c-4e3e-aec2-6edab02d8127 
Le niveau de service « TESTING » nest pas disponible aux unités de lorganisation admin.


VERIFIED: The unavailable service level message is currently translated in candlepin 0.8.33-1
Comment 8 Bryan Kearney 2014-09-29 15:05:03 EDT
These bugs were fixed during 7.0 but not moved to CLOSED. They have been delivered

Note You need to log in before you can comment on or make changes to this bug.