Bug 819828 - [ALL LANG][RHSM CLI] Unlocalized string 'This system does not support environments' in environments module.
[ALL LANG][RHSM CLI] Unlocalized string 'This system does not support environ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
: Translation
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-05-08 06:15 EDT by Lijun Li
Modified: 2012-06-20 08:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:57:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unlocalized string 'This system does not support environments' in environments module (18.61 KB, image/png)
2012-05-08 06:18 EDT, Lijun Li
no flags Details

  None (edit)
Description Lijun Li 2012-05-08 06:15:58 EDT
Description of problem:
Unlocalized string 'This system does not support environments' in environments module.

Version-Release number of selected component (if applicable):
subscription-manager-0.99.16-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install latest RHEL6.3 build (Snapshot-2).

2. Run command from terminal.
$ sudo subscription-manager environments --org=ORG

  
Actual results:
Unlocalized string 'This system does not support environments' in environments module.

Expected results:
It should be localized.

Additional info:
Comment 1 Lijun Li 2012-05-08 06:18:49 EDT
Created attachment 582950 [details]
Unlocalized string 'This system does not support environments' in environments module
Comment 3 Adrian Likins 2012-05-09 17:28:50 EDT
commit fce59903975271944fcc185aa5d7e97343819380
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed May 9 12:41:10 2012 -0400

    819828: Add translated strings for missing translations
    
    Not the greatest strings here, but they are translated
    already.

Headed to 0.99.18
Comment 5 Ankit Patel 2012-05-10 01:34:15 EDT
This particular messages is not marked for translations I can see from the code below:

File: subscription-manager-0.99.17/src/subscription_manager/managercli.py:

Source Code (Line 541): print "This system does not support environments."

It needs to be marked for translations so that it can come to PO/POT files for translators and then it could be translated.

Thanks!
Ankit
Comment 8 Lijun Li 2012-05-18 03:22:50 EDT
Verified, it's fixed on subscription-manager-0.99.18-1.el6.x86_64.
Comment 11 errata-xmlrpc 2012-06-20 08:57:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.