Bug 819862 - gearname_ctl.sh does not keep consistent between existing app and newly created app after run migrate
gearname_ctl.sh does not keep consistent between existing app and newly creat...
Status: CLOSED DUPLICATE of bug 819966
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 08:11 EDT by Johnny Liu
Modified: 2015-05-14 18:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 17:31:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-05-08 08:11:09 EDT
Description of problem:
For existing app, after migrate, the following is added into gearname_ctl.sh:
export CARTRIDGE_TYPE="<gear_cartridge_type>"

Then create a new app, check its gearname_ctl.sh, found there is such line.

From that, I did not found the meaning of migrate operation. For my understanding, the goal of migrate is to make existing app and new app keep insistent.

Version-Release number of selected component (if applicable):
migrate-2.0.11

How reproducible:
Always

Steps to Reproduce:
1. Launch devenv-stage_187
2. Create app - app1
3. Update packages to the latest version, then run migrate script
4. Create a new app - app2

  
Actual results:
Compared gearname_ctl.sh of app1 and app2, found the following line is only existing old app - app1.

export CARTRIDGE_TYPE="<gear_cartridge_type>"

Expected results:
Existing app and new app should keep insistent.

Additional info:
Comment 1 Rob Millner 2012-05-08 17:31:26 EDT
There was a bug preventing new apps from getting the correct "CARTRIDGE_TYPE" setting.

*** This bug has been marked as a duplicate of bug 819966 ***

Note You need to log in before you can comment on or make changes to this bug.