Bug 819977 - [abrt] kernel: BUG: unable to handle kernel NULL pointer dereference at 0000000000000020
[abrt] kernel: BUG: unable to handle kernel NULL pointer dereference at 00000...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:20df9657e2891b95c1a96e9aa82...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 15:13 EDT by Owen Johnson
Modified: 2012-05-08 17:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 17:10:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Owen Johnson 2012-05-08 15:13:37 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.7-1.fc16.x86_64 root=UUID=fe93cbfb-cd84-4203-b8ea-09c2c1490c25 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
kernel:         3.2.7-1.fc16.x86_64
reason:         BUG: unable to handle kernel NULL pointer dereference at 0000000000000020
time:           Thu 08 Mar 2012 08:51:08 PM CST

backtrace:
:BUG: unable to handle kernel NULL pointer dereference at 0000000000000020
:IP: [<ffffffff812662a1>] inode_has_perm+0x21/0x40
:PGD 12d09c067 PUD 12d06a067 PMD 0 
:Oops: 0000 [#1] SMP 
:CPU 3 
:Modules linked in: tcp_lp ppdev parport_pc lp parport fuse be2iscsi iscsi_boot_sysfs bnx2i cnic uio fcoe libfcoe libfc cxgb4i scsi_transport_fc scsi_tgt cxgb4 cxgb3i libcxgbi cxgb3 mdio 8021q garp stp llc ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack binfmt_misc arc4 uvcvideo videodev media v4l2_compat_ioctl32 microcode joydev asus_laptop sparse_keymap snd_hda_codec_hdmi serio_raw snd_hda_codec_realtek i2c_i801 iTCO_wdt iTCO_vendor_support atl1c intel_ips snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm iwlwifi mac80211 cfg80211 input_polldev snd_timer rfkill snd soundcore snd_page_alloc uinput nouveau ttm mxm_wmi wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 957, comm: systemd-logind Not tainted 3.2.7-1.fc16.x86_64 #1 ASUSTeK Computer Inc. U43Jc/U43Jc
:RIP: 0010:[<ffffffff812662a1>]  [<ffffffff812662a1>] inode_has_perm+0x21/0x40
:RSP: 0018:ffff88012d28fbd8  EFLAGS: 00010246
:RAX: 0000000000800000 RBX: ffff88012e7de0d0 RCX: 0000000000800000
:RDX: 0000000000800000 RSI: 0000000000000000 RDI: ffff88012d13e8a0
:RBP: ffff88012d28fbd8 R08: ffff88012d28fbe8 R09: 0000000000000000
:R10: ffff88012fb5a000 R11: ffff88012d28fbe8 R12: 0000000000000001
:R13: ffff88012e7de0d0 R14: ffff88012d230000 R15: ffff88003699f00e
:FS:  00007fc478bf17c0(0000) GS:ffff880137cc0000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
:CR2: 0000000000000020 CR3: 000000012d206000 CR4: 00000000000006e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process systemd-logind (pid: 957, threadinfo ffff88012d28e000, task ffff88012d230000)
:Stack:
: ffff88012d28fc78 ffffffff812671e1 0000000000000009 0000000000000000
: ffff88012e7de0d0 0000000000000000 0000000000000000 0000000000000000
: 0000000000000000 0000000000000000 0000000000000000 0000000000000000
:Call Trace:
: [<ffffffff812671e1>] selinux_inode_permission+0xd1/0x120
: [<ffffffff8126369c>] security_inode_permission+0x1c/0x30
: [<ffffffff81184978>] inode_permission+0x48/0x100
: [<ffffffff811867ea>] link_path_walk+0x1aa/0x880
: [<ffffffff8119cc00>] ? dcache_dir_lseek+0x160/0x160
: [<ffffffff811852ad>] ? path_init+0x2cd/0x3a0
: [<ffffffff81186ff8>] path_lookupat+0x58/0x740
: [<ffffffff8118427b>] ? getname_flags+0x3b/0x260
: [<ffffffff812c4327>] ? __strncpy_from_user+0x27/0x60
: [<ffffffff81187711>] do_path_lookup+0x31/0xc0
: [<ffffffff81188ab9>] user_path_at_empty+0x59/0xa0
: [<ffffffff811914df>] ? touch_atime+0x6f/0x160
: [<ffffffff8118b340>] ? fillonedir+0xd0/0xd0
: [<ffffffff8117e022>] sys_readlinkat+0x42/0xb0
: [<ffffffff810cdd62>] ? audit_syscall_entry+0x242/0x360
: [<ffffffff8117e0ab>] sys_readlink+0x1b/0x20
: [<ffffffff815e9d82>] system_call_fastpath+0x16/0x1b
:Code: 66 2e 0f 1f 84 00 00 00 00 00 55 48 89 e5 66 66 66 66 90 f6 46 0d 02 89 d0 75 21 48 8b 76 38 48 8b 7f 68 45 89 c1 49 89 c8 89 c1 <0f> b7 56 20 8b 7f 04 8b 76 1c e8 b0 fc ff ff 5d c3 31 c0 5d c3 
:RIP  [<ffffffff812662a1>] inode_has_perm+0x21/0x40
: RSP <ffff88012d28fbd8>
:CR2: 0000000000000020

smolt_data:
:
:
:General
:=================================
:UUID: cebe566c-174f-4940-8454-2a6836daa5f3
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4787.74
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU       M 450  @ 2.40GHz
:CPU Stepping: 5
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2400
:System Memory: 3754
:System Swap: 5807
:Vendor: ASUSTeK Computer Inc.
:System: U43Jc 1.0
:Form factor: Notebook
:Kernel: 3.3.2-6.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:68:4163:4135) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:69:4163:4135) pci, pcieport, PCI/PCI, Core Processor PCI Express x16 Root Port
:(4147:404:4163:4121) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:15152:4163:4135) pci, i801_smbus, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15145:4163:4135) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 4 port SATA AHCI Controller
:(32902:15113:4163:4135) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:4163:4135) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(32902:9288:4163:4135) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15164:4163:4135) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:4163:4135) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15204:4163:4135) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:131:32902:4869) pci, iwlwifi, NETWORK, Centrino Wireless-N 1000 BGN
:(32902:70:4163:4978) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15176:4163:4135) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 4
:(32902:15170:4163:4135) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:4163:4135) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15190:4163:4627) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(4318:2672:4163:4978) pci, nouveau, VIDEO, GT218 [GeForce 310M]
:(32902:15180:4163:4135) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 6
:(32902:11521:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:11362:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(6505:4195:4163:6176) pci, atl1c, ETHERNET, AR8131 Gigabit Ethernet
:(32902:11537:32902:32902) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11536:32902:32902) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11539:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11538:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 9405666 7791187 7697051 2359296 2207897 2207897
:/dev/sda5 /home ext4 4096 4096 4582399 4122703 3892803 1150560 1138475 1138475
:/dev/sda2 /boot ext4 1024 1024 508745 410329 384729 128016 127780 127780
:/dev/sdb1 WITHHELD vfat 32768 32768 62020 55717 55717 0 0 0
:
Comment 1 Dave Jones 2012-05-08 17:10:08 EDT
this looks like fallout from the i915 corruption bug that got fixed last month.

update to the latest kernel.

Note You need to log in before you can comment on or make changes to this bug.