Bug 820027 - [ALL LANG][RHSM CLI] Unlocalized string 'if supplied then list shows only ...' in list module help message
[ALL LANG][RHSM CLI] Unlocalized string 'if supplied then list shows only ......
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
: Translation
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-05-08 19:42 EDT by Lijun Li
Modified: 2012-06-20 08:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:57:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unlocalized string 'if supplied then list shows only ...' in list module help message (96.07 KB, image/png)
2012-05-08 19:44 EDT, Lijun Li
no flags Details

  None (edit)
Description Lijun Li 2012-05-08 19:42:15 EDT
Description of problem:
Unlocalized string 'if supplied then list shows only ...' in list module help message

Version-Release number of selected component (if applicable):
subscription-manager-0.99.16-1.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Install latest RHEL6.3 build (Snapshot-2).

2. Run command from terminal.
(Display help)

$ sudo subscription-manager list --help

  
Actual results:
Unlocalized string 'if supplied then list shows only ...' in list module help message

Expected results:
It should be localized.

Additional info:
Comment 1 Lijun Li 2012-05-08 19:44:24 EDT
Created attachment 583082 [details]
Unlocalized string 'if supplied then list shows only ...' in list module help message
Comment 4 Adrian Likins 2012-05-10 10:59:18 EDT
Looks like only the first line of the string got extracted into the message catalog.
Comment 5 Adrian Likins 2012-05-10 16:49:50 EDT
commit 36d862985cf76b193c4c8bddd728a7b2102a4969
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu May 10 11:06:00 2012 -0400

    820027: Fix unlocalized string blurb for "list --servicelevels"
    
    Only the first line of the string got pulled into the message
    catalog, but it was the important part anyway, so just use it
    so translations work.

Should be in 0.99.18
Comment 9 Lijun Li 2012-05-18 03:20:27 EDT
Verified, it's fixed on subscription-manager-0.99.18-1.el6.x86_64.
Comment 12 errata-xmlrpc 2012-06-20 08:57:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.