This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 820048 - RFE: Maven client should print helpful messages when translation files do not exist
RFE: Maven client should print helpful messages when translation files do not...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Maven (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Isaac Rooskov
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 21:44 EDT by Joyce Chang
Modified: 2015-08-06 01:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: 2
Clone Of:
Environment:
Last Closed: 2014-12-16 20:57:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joyce Chang 2012-05-08 21:44:33 EDT
Description of problem:
supposed project file structure is set as below:

working_dir/
    pot/
	xxx.pot
    zh-CN/
        xxx.po

if users didn't specify srcdir option when pushing translation files using maven tool, maven should give a warning or helpful message to let users know what exactly file that maven needs in order to successfully push po files 

Version-Release number of selected component (if applicable):
maven 1.6.0-alpha-2


How reproducible:
always

Steps to Reproduce:
1.create a project name "AboutFedora" and a project version "master"
2.open a terminal:mvn -B zanata:push -Dzanata.pushTrans

  
Actual results:
failed to push translation files(po files) to server but no warning was given. Though, source is pushed successfully. 

Expected results:
a warning should state no translation is pushed because failed to find <filename>.
Comment 1 Runa Bhattacharjee 2012-07-30 09:15:10 EDT
Request for technical evalutaion.
Comment 2 Sean Flanigan 2012-07-30 22:25:37 EDT
To avoid having too many warnings, we should probably only generate one warning per language if no files were found.  The warning could give the full filename it tried for the first file, which should help the user to work out where Zanata is looking for the files.

For example:

Warning: no translations found in locale zh-CN: first expected file was "working_dir/pot/zh-CN/xxx.po".  Please check the values of srcDir and transDir.

(This is a sign that the user should have used a srcDir value of "pot".)
Comment 3 Sean Flanigan 2012-11-14 20:14:14 EST
We could also add a warning (with an option to switch it off) when the source file path names start with something suspicious like "pot" or "src".  The warning could suggest the fix of changing srcDir to be $suspiciousPrefix.

Note You need to log in before you can comment on or make changes to this bug.