Bug 82005 - [PATCH] Support for Bulgarian
[PATCH] Support for Bulgarian
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-language (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Cormier
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-01-16 04:40 EST by Yanko Kaneti
Modified: 2013-01-10 16:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-11 16:39:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch with Bulgarian support (6.56 KB, patch)
2003-01-16 04:43 EST, Yanko Kaneti
no flags Details | Diff
UTF-8<->CP1251 patch for redhat-config-language.desktop (820 bytes, patch)
2003-01-29 19:51 EST, Yanko Kaneti
no flags Details | Diff

  None (edit)
Description Yanko Kaneti 2003-01-16 04:40:45 EST
Hi

Here is a patch that add support for Bulgarian along with a translation.

Cheers
Yanko

P.S. I have a cvs account on i18n.redhat.com, should I've tried to commit this
directly ?
Comment 1 Yanko Kaneti 2003-01-16 04:43:47 EST
Created attachment 89407 [details]
proposed patch with Bulgarian support
Comment 2 Brent Fox 2003-01-16 18:08:49 EST
pgampe is in change of all of our translations, so I'm transferring this bug to
him.  I'm not sure if you should commit directly to i18n.redhat.com or not.  Paul?
Comment 3 Paul Gampe 2003-01-23 00:03:20 EST
Yanko, yes the best way to proceed is to commit your translations directly to CVS.  Once the 
anaconda family of modules are fully translated we can begin the process of adding Bulgarian 
as a installation language option. 
Comment 4 Yanko Kaneti 2003-01-23 03:52:29 EST
I think there is some misunderstanding.
The patch has the Bulgarian translation _and_ the support for the Bulgarian
locale in redhat-config-language.

I've commited the bulgarian translation but I dont' have the permission to
commit the other parts of it.

The support for Bulgarian in redhat-config-language should not be tied to the
availability of the other translations,  after all Bulgarian cannot be used for
instalation and in most situations currerntly the bulgarian locale is not even
installed. The support in r-c-l would only show up if the user has manualy
localedef-ed bg_BG. 
This is the same as the current support for other locales (say be_BY.UTF-8 utf8
latarcyrheb-sun16 Belarusian) which are not officially suported by the installation.
Comment 5 Brent Fox 2003-01-23 14:34:02 EST
Hi Yanko.  Thanks for committing the translations to cvs.  I think that cvs is
set up so that translators have commit access to the translation modules but not
the source code.  I added the patch that applies to locale-list and committed
that to cvs.  

redhat-config-language-1.0.2-2 should include Bulgarian support and should
appear in Rawhide in the next day or so.  Thanks again for your help.  QA,
please test  to see that redhat-config-language now configures
/etc/sysconfig/i18n for Bulgarian now.
Comment 6 Yanko Kaneti 2003-01-29 11:35:44 EST
1.0.2-2 works for me

Thanks
Comment 7 Yanko Kaneti 2003-01-29 19:51:06 EST
Created attachment 89710 [details]
UTF-8<->CP1251 patch for redhat-config-language.desktop

Realized there is a  problem with my translation of
redhat-config-language.desktop
I've translated the entries in UTF-8  but didn't notice the encoding of this
particular desktop file is defined as Legacy-Mixed.  
Either you plan on moving the desktop file to Encoding=UTF-8 (as most of the
other redhat-config-* files.  Or you could apply the attached patch which
recodes the [bg] entries to CP1251.

Sorry if thats any trouble.
Comment 8 Yanko Kaneti 2003-02-06 08:18:04 EST
I can see that 1.0.3-2  fixes the .desktop encoding problem

Thanks

Note You need to log in before you can comment on or make changes to this bug.