Bug 820056 - kvm-unit-tests: multiple nmi: FAIL
kvm-unit-tests: multiple nmi: FAIL
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Linux
medium Severity unspecified
: rc
: ---
Assigned To: Gleb Natapov
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 22:58 EDT by Amos Kong
Modified: 2015-05-24 20:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 10:32:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amos Kong 2012-05-08 22:58:35 EDT
Description of problem:

# qemu-kvm  -nodefaults -serial stdio -vnc :0 -chardev file,id=testlog,path=/tmp/testlog-20120509-094418-65Qx -device testdev,chardev=testlog -m 512 -smp 2 -kernel 'x86/apic.flat' --enable-kvm
enabling apic
enabling apic
enabling apic
paging enabled
cr0 = 80010011
cr3 = 1ffff000
cr4 = 20
apic version: 50014
apic existence: PASS
enabling apic
x2apic not detected
self ipi: PASS
ioapic interrupt: PASS
ioapic simultaneous interrupt: PASS
nmi-after-sti: PASS
multiple nmi: FAIL
^^^^^^^^^^^^^^^^^^
tsc deadline timer not detected

summary: 6 tests, 1 failures


Version-Release number of selected component (if applicable):
# uname -r && rpm -q qemu-kvm
host kernel: 2.6.32-262.el6.x86_64
qemu-kvm-0.12.1.2-2.285.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. compile kvm-unit-tests
2. execute apic test
# qemu-kvm  -nodefaults -serial stdio -vnc :0 -chardev file,id=testlog,path=/tmp/testlog-20120509-094418-65Qx -device testdev,chardev=testlog -m 512 -smp 2 -kernel 'x86/apic.flat' --enable-kvm
  
Actual results:
multiple nmi testing failed

Expected results:
all tests pass

Additional info:
all tests pass with 3.4.0-rc4 host kernel
Comment 1 Amos Kong 2012-05-08 23:12:28 EDT
[PATCH kvm-unit-tests] apic: test simultaneous NMIs
http://marc.info/?l=kvm&m=131609772126630&w=2
Comment 2 Dor Laor 2012-05-10 07:52:10 EDT
Is it only the tsc deadline timer? It's not enabled for 6.3.
AFAIK we have a BZ open for 6.4 for the deadline timer
Comment 3 Amos Kong 2012-05-10 08:05:16 EDT
(In reply to comment #2)
> Is it only the tsc deadline timer? It's not enabled for 6.3.
> AFAIK we have a BZ open for 6.4 for the deadline timer

This bug is reported for test_multiple_nmi(), not test_tsc_deadline_timer().
Comment 4 Gleb Natapov 2012-05-14 10:32:31 EDT
(In reply to comment #0)
> Expected results:
> all tests pass

This is not expected result. kvm-unit-test suppose to work without failures only on upstream kernels. It is well known that many tests fail on rhel6, but we do not backport fixes just because unit test fail. Closing the bug. If the bug cause real problems for real guest software please provide info and reopen.
Comment 5 Gleb Natapov 2012-05-14 10:37:53 EDT
In case we will want to fix it the upstream commit is  7460fb4a340033107530df19e7e125bd0969bfb2

Note You need to log in before you can comment on or make changes to this bug.