Bug 820106 - anaconda transfers all guest anaconda logs into syslog on host with virtio and rsyslog
anaconda transfers all guest anaconda logs into syslog on host with virtio an...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 03:52 EDT by Hongqing Yang
Modified: 2013-01-10 01:46 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-18.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-03 20:27:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog transferred to host (261.28 KB, text/plain)
2012-05-09 03:52 EDT, Hongqing Yang
no flags Details
anaconda log on guest (17.49 KB, text/plain)
2012-05-09 04:50 EDT, Hongqing Yang
no flags Details
program log on guest (48.89 KB, text/plain)
2012-05-09 04:50 EDT, Hongqing Yang
no flags Details
syslog on guest (63.72 KB, text/plain)
2012-05-09 04:51 EDT, Hongqing Yang
no flags Details
analog (7.98 KB, text/plain)
2012-05-09 04:52 EDT, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2012-05-09 03:52:47 EDT
Created attachment 583174 [details]
syslog transferred to host

Description of problem:

This follows the introduction http://fedoraproject.org/wiki/Anaconda/Loggingto transfer all guest anaconda logs to the guest by virtio and rsyslog. But all the anaconda logs are crashed into syslog and there is only syslog file exists in the host directory.

Version-Release number of selected component (if applicable):
F17 Final TC3

How reproducible:


Steps to Reproduce:
1.create a guest
2.edit guest define xml file, add the following into it.
<channel type='tcp'>
  <source mode='connect' host='127.0.0.1' service='6080'/>
  <target type='virtio' name='org.fedoraproject.anaconda.log.0'/>
</channel>

3. start the rsyslog with analog.py script in attachment by running
$ eval `scripts/analog -p 6080 -s -o ./rsyslogd.conf /tmp/autoqa/log`
4. restart guest and proceed the installation.
5. there is only file 'syslog' in directory /tmp/autoqa/log/anaconda
  
Actual results:
only syslog file exists and all logs are crashed into it.

Expected results:

all guest anaconda logs are transferred to the host.

Additional info:
Comment 1 Hongqing Yang 2012-05-09 04:50:07 EDT
Created attachment 583190 [details]
anaconda log on guest
Comment 2 Hongqing Yang 2012-05-09 04:50:53 EDT
Created attachment 583191 [details]
program log on guest
Comment 3 Hongqing Yang 2012-05-09 04:51:17 EDT
Created attachment 583192 [details]
syslog on guest
Comment 4 Hongqing Yang 2012-05-09 04:52:07 EDT
Created attachment 583193 [details]
analog
Comment 5 Kamil Páral 2012-05-09 07:13:59 EDT
So basically different events are no longer split into different log files, instead all of them are merged into one.

I have compared attached analog.py and the upstream one [1], and they are not fully equal, but there seems to be only slight changes that should not have any big impact.

Now the question is - is anaconda logging important for some use cases, so that we definitely need to have this fixed in F17 Final? For example does Beaker or some other tools rely on it?

[1] http://git.fedorahosted.org/git/?p=anaconda.git;a=blob_plain;f=scripts/analog;hb=HEAD

Note You need to log in before you can comment on or make changes to this bug.