Bug 820169 - The useless error message will be presented when try to change to the duplicated domain name or the name in blacklist.
The useless error message will be presented when try to change to the duplica...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 06:19 EDT by yquan
Modified: 2015-05-14 21:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:43:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot1 (130.71 KB, image/png)
2012-06-25 03:10 EDT, Yujie Zhang
no flags Details
screenshot2 (131.84 KB, image/png)
2012-06-25 03:10 EDT, Yujie Zhang
no flags Details

  None (edit)
Description yquan 2012-05-09 06:19:37 EDT
Description of problem:
The useless error message "Your namespace must be letters or numbers with no spaces or symbols." will be presented when try to change to the duplicated domain name or the name in blacklist.

Version-Release number of selected component (if applicable):
devenv_1762

How reproducible:Always

Steps to Reproduce:
1.Log in the openshift website and go to the account page.
2.Go to the domain changing page.
3.Input duplicate name or the name in Blacklist.
4.click save
  
Actual results:
It will return useless error message.

Expected results:
The "Your namespace must be letters or numbers with no spaces or symbols." message should not be presented.
Additional info:
Comment 1 Clayton Coleman 2012-06-18 15:34:13 EDT
Fixed, returns distinct errors now.
Comment 2 Yujie Zhang 2012-06-19 02:39:52 EDT
(In reply to comment #1)
Not sure if the commit has finished, tested this issue on devenv_1857, it still exists.
Comment 3 Clayton Coleman 2012-06-22 12:06:44 EDT
Please provide me with the exact old and new domain names you are trying.
Comment 4 Yujie Zhang 2012-06-25 03:09:44 EDT
(In reply to comment #3)
hi Clayton , the sentence of "Your namespace must be letters or numbers with no spaces or symbols." will always be originally presented below the domain name form, it's not related to the namespace I used, when I input the invalid domain name, it will turn to be red. Details see in attachment, not sure if this is expected.
Comment 5 Yujie Zhang 2012-06-25 03:10:07 EDT
Created attachment 594117 [details]
screenshot1
Comment 6 Yujie Zhang 2012-06-25 03:10:31 EDT
Created attachment 594118 [details]
screenshot2
Comment 7 Clayton Coleman 2012-06-25 09:21:52 EDT
I see what you're referring to.  This is intentional - we don't want to remove a useful help message when the real error shows up, but we have logic that highlights the invalid input in red.  It would complicate lots of other things to not highlight this text.
Comment 8 Yujie Zhang 2012-06-25 22:11:31 EDT
(In reply to comment #7)
OK. Since this is expected, then I will verify this bug, thanks.
Comment 9 Xiaoli Tian 2012-07-01 23:20:54 EDT
Since it's closed, remove the need_info tag

Note You need to log in before you can comment on or make changes to this bug.