Bug 820201 - [abrt] git-cola-1.7.6-1.fc16: subprocess.py:1249:_execute_child:OSError: [Errno 2] No such file or directory
[abrt] git-cola-1.7.6-1.fc16: subprocess.py:1249:_execute_child:OSError: [Err...
Status: CLOSED DUPLICATE of bug 804222
Product: Fedora
Classification: Fedora
Component: git-cola (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
abrt_hash:e30e45bdabaef8e665478770e80...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 07:37 EDT by Jerzy Spendel
Modified: 2012-05-09 12:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 12:20:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerzy Spendel 2012-05-09 07:37:48 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/git-cola
executable:     /usr/bin/git-cola
kernel:         3.1.0-7.fc16.x86_64
reason:         subprocess.py:1249:_execute_child:OSError: [Errno 2] No such file or directory
time:           Wed 09 May 2012 01:26:59 PM CEST
uid:            1000
username:       jerzy

backtrace:
:subprocess.py:1249:_execute_child:OSError: [Errno 2] No such file or directory
:
:Traceback (most recent call last):
:  File "/usr/share/git-cola/lib/cola/qtutils.py", line 60, in broadcast
:    cola.notifier().broadcast(signal, *local_args, **local_opts)
:  File "/usr/share/git-cola/lib/cola/notification.py", line 26, in broadcast
:    self.emit(signal, *args, **opts)
:  File "/usr/share/git-cola/lib/cola/notification.py", line 33, in emit
:    fxn(*args, **opts)
:  File "/usr/share/git-cola/lib/cola/cmdfactory.py", line 73, in run
:    return self.do(signal, *args, **opts)
:  File "/usr/share/git-cola/lib/cola/cmdfactory.py", line 83, in do
:    ok, result = self._do(cmdobj)
:  File "/usr/share/git-cola/lib/cola/cmdfactory.py", line 90, in _do
:    result = cmdobj.do()
:  File "/usr/share/git-cola/lib/cola/cmds.py", line 811, in do
:    utils.fork([browser, '--all'])
:  File "/usr/share/git-cola/lib/cola/utils.py", line 100, in fork
:    return subprocess.Popen(encoded_args).pid
:  File "/usr/lib64/python2.7/subprocess.py", line 679, in __init__
:    errread, errwrite)
:  File "/usr/lib64/python2.7/subprocess.py", line 1249, in _execute_child
:    raise child_exception
:OSError: [Errno 2] No such file or directory
:
:Local variables in innermost frame:
:errread: None
:c2pread: None
:gc_was_enabled: True
:errwrite: None
:shell: False
:errpipe_write: 25
:executable: 'gitk'
:close_fds: False
:self: <subprocess.Popen object at 0x2a0c1d0>
:env: None
:cwd: None
:child_exception: OSError(2, 'No such file or directory')
:args: ['gitk', '--all']
:fd: None
:c2pwrite: None
:data: 'cexceptions\nOSError\np0\n(I2\nS\'No such file or directory\'\np1\ntp2\nRp3\n(dp4\nS\'child_traceback\'\np5\nS\'Traceback (most recent call last):\\n  File "/usr/lib64/python2.7/subprocess.py", line 1201, in _execute_child\\n    os.execvp(executable, args)\\n  File "/usr/lib64/python2.7/os.py", line 344, in execvp\\n    _execvpe(file, args)\\n  File "/usr/lib64/python2.7/os.py", line 380, in _execvpe\\n    func(fullname, *argrest)\\nOSError: [Errno 2] No such file or directory\\n\'\np6\nsb.'
:creationflags: 0
:errpipe_read: 23
:preexec_fn: None
:p2cread: None
:startupinfo: None
:p2cwrite: None
:universal_newlines: False
Comment 1 Kevin Kofler 2012-05-09 12:20:35 EDT

*** This bug has been marked as a duplicate of bug 804222 ***

Note You need to log in before you can comment on or make changes to this bug.