Bug 820223 - "uninitialized constant MCollective::Agent::Libra::Facter" is seen in broker log when creating district
"uninitialized constant MCollective::Agent::Libra::Facter" is seen in broker ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 08:26 EDT by Johnny Liu
Modified: 2015-05-14 21:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: devenv_1807
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:58:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-05-09 08:26:32 EDT
Description of problem:
Create a district using rhc-admin-ctl-district, and add a node to this district, it return success. But in broker log, I found the following message:
DEBUG: rpc_exec_direct: rpc_client=#<MCollective::RPC::Client:0x7f3fad07bc48>
DEBUG: rpc_client.custom_request('set_district', {:uuid=>"e9eb9d1afb114b95925cdec2aef1cca0", :active=>true}, @id, {'identity' => @id})
DEBUG: [#<MCollective::RPC::Result:0x7f3fad047bc8 @action="set_district", @agent="libra", @results={:sender=>"ip-10-101-1-31", :data=>nil, :statusmsg=>"uninitialized constant MCollective::Agent::Libra::Facter", :statuscode=>5}>]
[#<MCollective::RPC::Result:0x7f3fad047bc8 @action="set_district", @agent="libra", @results={:sender=>"ip-10-101-1-31", :data=>nil, :statusmsg=>"uninitialized constant MCollective::Agent::Libra::Facter", :statuscode=>5}>]
MongoDataStore.add_district_node(e9eb9d1afb114b95925cdec2aef1cca0,ip-10-101-1-31)


It looks like does not affect app creation, but I think this error should be fixed.

Version-Release number of selected component (if applicable):
devenv_1762

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rony Gong 2012-05-30 05:46:53 EDT
verifeid on devenv_1806
with result:
ongoDataStore.find_district_with_node(ip-10-110-162-229)

DEPRECATION WARNING: config.action_view.debug_rjs will be removed in 3.1, from 3.1 onwards you will need to install prototype-rails to continue to use RJS templates . (called from /var/www/stickshift/broker/config/environment.rb:5)
MongoDataStore.find_district_by_name(dist2)

MongoDataStore.find_district_with_node(ip-10-110-162-229)

DEBUG: rpc_exec_direct: rpc_client=#<MCollective::RPC::Client:0x7f64a36c9120>
DEBUG: rpc_client.custom_request('set_district', {:active=>true, :uuid=>"25d9ce04945a4b45b67f53243d1f1569"}, @id, {'identity' => @id})
DEBUG: [#<MCollective::RPC::Result:0x7f64a3681cd0 @results={:sender=>"ip-10-110-162-229", :statusmsg=>"OK", :statuscode=>0, :data=>{:output=>"", :exitcode=>0}}, @action="set_district", @agent="libra">]
[#<MCollective::RPC::Result:0x7f64a3681cd0 @results={:sender=>"ip-10-110-162-229", :statusmsg=>"OK", :statuscode=>0, :data=>{:output=>"", :exitcode=>0}}, @action="set_district", @agent="libra">]
MongoDataStore.add_district_node(25d9ce04945a4b45b67f53243d1f1569,ip-10-110-162-229)

MongoDataStore.find_district_by_name(dist2)

Note You need to log in before you can comment on or make changes to this bug.