Bug 820227 - Cannot start New Server VM (NPE @ QuotaManager.validateVdsGroupQuota)
Cannot start New Server VM (NPE @ QuotaManager.validateVdsGroupQuota)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Maor
Daniel Paikov
virt
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 08:36 EDT by David Botzer
Modified: 2015-09-22 09 EDT (History)
11 users (show)

See Also:
Fixed In Version: SI6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:04:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Botzer 2012-05-09 08:36:10 EDT
Description of problem:

I cannot start a newly created Server VM
I get "Oops Message"
----
Error: WinXPtst:
   * - General command validation failure. 
----

Version-Release number of selected component (if applicable):
rhevm-engine 3.1, SI3

How reproducible:
Always

Steps to Reproduce:
1.I created a vm that works fine
2.I exported it to template (WinXP)
3.I created a new Server VM using this template
  
Actual results:
I cannot start this VM, I get "Oops Message"
Error: WinXPtst:
   * - General command validation failure. 

Expected results:
Should start successfuly

Additional info:
And I see error in log:

2012-05-09 13:42:30,723 ERROR [org.ovirt.engine.core.bll.RunVmCommand] (ajp--0.0.0.0-8009-7) Error during CanDoActionFailure.: java.lang.NullPointerException
    at org.ovirt.engine.core.bll.QuotaManager.validateVdsGroupQuota(QuotaManager.java:268) [engine-bll.jar:]
    at org.ovirt.engine.core.bll.RunVmCommand.validateQuota(RunVmCommand.java:358) [engine-bll.jar:]
    at org.ovirt.engine.core.bll.CommandBase.InternalCanDoAction(CommandBase.java:477) [engine-bll.jar:]
    at org.ovirt.engine.core.bll.CommandBase.CanDoActionOnly(CommandBase.java:235) [engine-bll.jar:]
    at org.ovirt.engine.core.bll.MultipleActionsRunner.Execute(MultipleActionsRunner.java:70) [engine-bll.jar:]
    at org.ovirt.engine.core.bll.Backend.runMultipleActionsImpl(Backend.java:432) [engine-bll.jar:]
    at org.ovirt.engine.core.bll.Backend.runMultipleActionsImpl(Backend.java:446) [engine-bll.jar:]
    at org.ovirt.engine.core.bll.Backend.RunMultipleActions(Backend.java:407) [engine-bll.jar:]
    at sun.reflect.GeneratedMethodAccessor256.invoke(Unknown Source) [:1.6.0_24]
Comment 1 Yaniv Kaul 2012-05-09 08:41:45 EDT
Duplicate of upstream https://bugzilla.redhat.com/show_bug.cgi?id=820131 ?
Comment 2 Haim 2012-05-09 09:36:11 EDT
(In reply to comment #1)
> Duplicate of upstream https://bugzilla.redhat.com/show_bug.cgi?id=820131 ?

yes, this part of the code is not implemented yet by DEV, meaning, if you happen to perform any of move or copy image, you will hit this. 
please set quota to disabled (audit doesn't work as well).
Comment 3 David Botzer 2012-05-09 09:47:19 EDT
Ok,
Quota disabled, VM is able to start,
David,
Comment 4 Maor 2012-05-16 10:42:42 EDT
Post suggestion solution in http://gerrit.ovirt.org/#change,4475
Comment 5 Maor 2012-05-16 10:56:06 EDT
Fixed at commit #00ac698428efd0d9a29933f599df9d31421c2a2d
Comment 7 Daniel Paikov 2012-07-15 10:46:06 EDT
Checked on si9.1.

Note You need to log in before you can comment on or make changes to this bug.