Bug 820277 - Blacklist filter doesn't work
Blacklist filter doesn't work
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sayli Karmarkar
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 10:01 EDT by Ashley Penney
Modified: 2015-03-22 21:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 14:29:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ashley Penney 2012-05-09 10:01:42 EDT
Description of problem:

When I apply a blacklist filter to my puppet repos it doesn't work.


Version-Release number of selected component (if applicable):

1.1.8

How reproducible:

Every day, baby, every day.

Log output:


2012-05-09 13:46:48,936 31555:139696629872384: pulp.server.api.repo_sync:INFO: repo_sync:265 Sync invoked for repo <ops-stable-rhel-5-x86_64-puppet_products>
2012-05-09 13:46:48,938 31555:139696629872384: pulp.server.api.repo_sync:INFO: repo_sync:279 Sync of ops-stable-rhel-5-x86_64-puppet_products starting, skip_dict = {}
2012-05-09 13:46:48,942 31555:139696629872384: pulp.server.api.synchronizers:INFO: synchronizers:1264 sync of /var/lib/pulp//repos/ops-unstable-rhel-5-x86_64-puppet_products for repo ops-stable-rhel-5-x86_64-puppet_products
2012-05-09 13:46:49,070 31555:139696629872384: pulp.server.api.synchronizers:INFO: synchronizers:862 Found 62 packages in /var/lib/pulp//repos/ops-unstable-rhel-5-x86_64-puppet_products
2012-05-09 13:46:49,073 31555:139696629872384: pulp.server.api.synchronizers:INFO: synchronizers:874 Found 0 delta rpm packages in /var/lib/pulp//repos/ops-unstable-rhel-5-x86_64-puppet_products
2012-05-09 13:46:49,074 31555:139696629872384: pulp.server.api.synchronizers:INFO: synchronizers:1272 Repo filters : [u'mcollective']
2012-05-09 13:46:49,083 31555:139696629872384: pulp.server.api.synchronizers:INFO: synchronizers:1275 combined whitelist packages = []
2012-05-09 13:46:49,084 31555:139696629872384: pulp.server.api.synchronizers:INFO: synchronizers:1276 combined blacklist packages = [u'mcollective-2.*']
2012-05-09 13:46:50,035 31555:139696629872384: pulp.server.api.synchronizers:INFO: synchronizers:983 Working on 0/62
2012-05-09 13:46:50,149 31555:139696629872384: pulp.server.api.synchronizers:INFO: synchronizers:1011 Finished copying 62 packages
2012-05-09 13:46:50,151 31555:139696629872384: pulp.server.api.synchronizers:INFO: synchronizers:874 Found 0 delta rpm packages in /var/lib/pulp//repos/ops-unstable-rhel-5-x86_64-puppet_products
2012-05-09 13:46:50,152 31555:139696629872384: pulp.server.api.synchronizers:INFO: synchronizers:1107 No image files to import
2012-05-09 13:46:50,154 31555:139696629872384: pulp.server.api.synchronizers:INFO: synchronizers:1329 Copying repodata from /var/lib/pulp//repos/ops-unstable-rhel-5-x86_64-puppet_products/repodata to /var/lib/pulp//repos/ops-stable-rhel-5-x86_64-puppet_products/repodata

Verification it doesn't work:


[root@per5-ops-pulp1 pulp]# pulp-admin repo content --id=ops-stable-rhel-5-x86_64-puppet_products | grep mcollective
mcollective-client-1.2.1-1.el5.noarch.rpm
mcollective-common-1.2.1-1.el5.noarch.rpm
mcollective-1.2.1-1.el5.noarch.rpm
mcollective-client-2.0.0-1.el5.noarch.rpm
mcollective-common-2.0.0-1.el5.noarch.rpm
Comment 1 Sayli Karmarkar 2012-05-09 13:59:58 EDT
Not sure I understand correctly. Black filter regex is 'mcollective-2.*' and I don't see any packages satisfying that regex (starting with 'mcollective-2.') in repo content output pasted above. I believe you wanted to add regex 'mcollective-1.2.*'.
Comment 2 Sayli Karmarkar 2012-05-09 14:08:19 EDT
Also verified that filters are working correctly in 1.1.8 - 

$ pulp-admin filter list
+------------------------------------------+
              Available Filters
+------------------------------------------+

Id           :               	foo                      
Description  :               	foo                      
Type         :               	blacklist                
Package List :               	['pulp-dev.py', 'pulp*'] 


$ pulp-admin repo clone --id test --clone_id test-clone1 -f foo -F
Repository [test] is being cloned as [test-clone1]
Clone: Finished
Item Details: 
RPMs: 14/21

$ pulp-admin repo sync --id test-clone1 -F
Sync for repository test-clone1 started
Sync: Finished
0/21 new items downloaded
21/21 existing items processed

Item Details: 
RPMs: 14/21

$ pulp-admin repo content --id test-clone1
+------------------------------------------+
           Contents of test-clone1
+------------------------------------------+

Packages in test-clone1: 

gofer-package-0.68-2.fc16.noarch.rpm
python-okaara-1.0.14-1.fc16.noarch.rpm
python-isodate-0.4.4-4.pulp.fc16.noarch.rpm
mod_wsgi-3.3-3.pulp.fc16.x86_64.rpm
python-gofer-0.68-2.fc16.noarch.rpm
python-webpy-0.32-8.fc16.noarch.rpm
python-oauth2-1.5.170-2.pulp.fc16.noarch.rpm
mod_wsgi-debuginfo-3.3-3.pulp.fc16.x86_64.rpm
python-qpid-0.7.946106-1.fc16.noarch.rpm
python-rhsm-0.96.4-1.fc16.noarch.rpm
grinder-0.1.3-1.fc16.noarch.rpm
gofer-0.68-2.fc16.noarch.rpm
m2crypto-debuginfo-0.21.1.pulp-7.fc16.x86_64.rpm
m2crypto-0.21.1.pulp-7.fc16.x86_64.rpm
Comment 3 Ashley Penney 2012-05-09 14:18:15 EDT
I worked with prad on this and it looks like the repos themselves were damaged.  Some of the packages I was trying to filter were undeletable.  We ended up recreating/cloning everything from scratch and now the filters are applying properly!

Thanks,
Comment 4 Sayli Karmarkar 2012-05-09 14:29:03 EDT
Closing it as NOTABUG as per above comment.

Note You need to log in before you can comment on or make changes to this bug.