Bug 820299 - Communication with server receives some unknown errors.
Communication with server receives some unknown errors.
Status: CLOSED CURRENTRELEASE
Product: TCMS
Classification: Other
Component: Usability (Show other bugs)
3.7.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.7.0
Assigned To: June Zhang
tools-bugs
: Regression, TestBlocker
Depends On:
Blocks: 593666
  Show dependency treegraph
 
Reported: 2012-05-09 10:44 EDT by Petr Sklenar
Modified: 2012-05-11 03:04 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-11 01:53:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Still fails - error returned after trying to edit a test case (75.70 KB, image/png)
2012-05-10 11:09 EDT, David Spalding
no flags Details

  None (edit)
Description Petr Sklenar 2012-05-09 10:44:24 EDT
Description of problem:
I filled ticket but it looks like bug in tcms:

ticket was:
[engineering.redhat.com #152653] AutoReply: tcms: Commnucation with server got some unknown errors.
to be sure writing to this list:

Version-Release number of selected component (if applicable):
Nitrate 3.7.0 

How reproducible:
deterministic

Steps to Reproduce:
1, looking at https://tcms.engineering.redhat.com/run/38090/#caserun_1090524

waiting waiting waiting ...
Commnucation with server got some unknown errors.

opening whatever case, then I can see:

    Sorry, This is a service error.
    1.Please check your operation , try it again;
    2.You can contact the administrator or developer.
    GO BACK

# date
Wed May  9 09:03:18 EDT 2012

xmlrpc says:
xmlrpclib.Fault: <Fault 1: 'DatabaseError: (1146, "Table \'testopia.tcms_linkrefs\' doesn\'t exist")'>

  
Actual results:
data lost?

xmlrpc says:
xmlrpclib.Fault: <Fault 1: 'DatabaseError: (1146, "Table \'testopia.tcms_linkrefs\' doesn\'t exist")'>


webUI says
    Sorry, This is a service error.
    1.Please check your operation , try it again;
    2.You can contact the administrator or developer.
    GO BACK



Expected results:
no fail, no data lost
I can see my test case results

Additional info:
ticket
[engineering.redhat.com #152653]
Comment 1 Ales Zelinka 2012-05-09 12:36:23 EDT
This affects all test-case-runs in all test-runs I've tried. We can't use TCMS at all. Please hotfix TCMS as soon as possible. 

Thanks in advance
Comment 2 David Spalding 2012-05-09 18:09:27 EDT
I can't edit any test cases after creation, also can't edit cloned cases. 

This will cause a significant block for pre-R12 planning and execution. 

Adding my voice ... please investigate and resolve ASAP. 

https://tcms.engineering.redhat.com/case/166636/?from_plan=5855

https://tcms.engineering.redhat.com/case/166633/?from_plan=5855
https://tcms.engineering.redhat.com/case/166634/?from_plan=5855
https://tcms.engineering.redhat.com/case/166635/?from_plan=5855

https://tcms.engineering.redhat.com/case/166632/edit/?from_plan= generates
the 500 error.
Comment 3 Victor Chen 2012-05-09 23:05:23 EDT
The problem was caused by a missing step during upgrade, recovered.
Comment 4 Ales Zelinka 2012-05-10 04:48:03 EDT
I can open test-case-runs again. Thank you for the quick fix.
Comment 5 Petr Sklenar 2012-05-10 05:12:45 EDT
hello much better, thanks for the fix.

But there is some minor issue.

Look at below of the page:
https://tcms.engineering.redhat.com/run/36600/
https://tcms.engineering.redhat.com/run/38469/
https://tcms.engineering.redhat.com/run/35561/

there are error at the bottom of the page:
All these fields are required.
Name * (64 characters at most) URL *

--
have no idea what's expecting to be there
Comment 6 David Spalding 2012-05-10 09:31:03 EDT
(In reply to comment #3)
> The problem was caused by a missing step during upgrade, recovered.

Can we add some basic validation into the upgrade procedure, to prevent future 
calamities? 


(In reply to comment #5)
> 
> But there is some minor issue.
> 
> Look at below of the page:
> https://tcms.engineering.redhat.com/run/36600/
> https://tcms.engineering.redhat.com/run/38469/
> https://tcms.engineering.redhat.com/run/35561/
> 
> there are error at the bottom of the page:
> All these fields are required.
> Name * (64 characters at most) URL *
> 
> --
> have no idea what's expecting to be there

I don't see the errors on those runs at this time.
Comment 7 David Spalding 2012-05-10 11:09:11 EDT
Created attachment 583607 [details]
Still fails - error returned after trying to edit a test case

I can create and save a new test case, but "Save and Continue editing" results in the error (attached). I've tried with test cases previously authored, and new test cases:



https://tcms.engineering.redhat.com/case/166686/?from_plan=5855
https://tcms.engineering.redhat.com/case/166687/?from_plan=5855
Comment 8 Martin Cermak 2012-05-10 12:26:40 EDT
I can confirm testcases are still not editable at this moment. This is important, please, have a look at it soon. Thanks.
Comment 9 jianchen 2012-05-11 01:53:40 EDT
This bug was Fixed.
This bug raised because tcms-3.7.0's deploy steps . 
I sincerely apologize for this bug.

Note You need to log in before you can comment on or make changes to this bug.