Bug 820390 - Launching an AppForm with specific characteristics causes error
Launching an AppForm with specific characteristics causes error
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jozef Zigmund
Rehana
: ZStream
Depends On:
Blocks: 826115
  Show dependency treegraph
 
Reported: 2012-05-09 15:46 EDT by james labocki
Modified: 2012-12-04 10:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 826115 (view as bug list)
Environment:
Last Closed: 2012-12-04 10:07:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
successful start of application (341.37 KB, image/png)
2012-05-29 09:57 EDT, Jozef Zigmund
no flags Details
app launched (67.67 KB, image/png)
2012-09-24 06:54 EDT, Aziza Karol
no flags Details

  None (edit)
Description james labocki 2012-05-09 15:46:59 EDT
Description of problem:

When trying to launch an AppForm in which the following characteristics are in place, it fails with the error:

           Error:   Failed to launch following component blueprints:   student9-componentoutline-template500: Parameter name must e 50
characters or less

           Characteristics

           compnent outline: student9-componentoutline-template
           blueprint: student9-blueprint
           appform name: student9-appform1
Comment 1 Dave Johnson 2012-05-10 17:20:57 EDT
Checked this out and it is there... I remembered seeing bug 773402 but that covers the deployment name field being more than 50 characters

That same check needs to include the appended component outline name (plus the slash) when checking the length
Comment 2 Hugh Brock 2012-05-11 10:20:23 EDT
Angus, this looks like a low-risk fix -- if so, let's put it on the list for Z. If not please clear the 1.0.z flag.
Comment 3 Jozef Zigmund 2012-05-29 09:56:33 EDT
I tried to reproduce that bug, but I could not. I attached a screenshot of successful starting Application.

Component outline: student9-componentoutline-template
Blueprint: student9-blueprint
Application name: student9-blueprint2

Tested on 1.0.1 branch, last commit # 8552fa5732edad7f7b0ae059eb2ba7368f992aeb

I've set NEEDINFO tag in this BZ.
Comment 4 Jozef Zigmund 2012-05-29 09:57:39 EDT
Created attachment 587418 [details]
successful start of application
Comment 7 Aziza Karol 2012-09-24 06:53:38 EDT
This issue is not reproducible. application started successfully. see attached screenshot.

Base of Dave's comment a check is required for component outline name if the name is more the 50 characters. To track this issue  i have logged:https://bugzilla.redhat.com/show_bug.cgi?id=829291


verified:
rpm -qa | grep aeolus
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
Comment 8 Aziza Karol 2012-09-24 06:54:13 EDT
Created attachment 616466 [details]
app launched
Comment 10 errata-xmlrpc 2012-12-04 10:07:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.