Bug 820399 - Disable gem updates
Disable gem updates
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity low (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 16:01 EDT by james labocki
Modified: 2013-03-27 16:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 12:13:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2012-05-09 16:01:38 EDT
Description of problem:
gem update seems to work. We should disable gem updates from rubygems.org. See gem sources -l
Comment 1 Lukas Zapletal 2012-05-15 05:42:57 EDT
I am not sure this is CloudForms issue. Gem is a system-wide tool, do not confuse this with Bundler (Gemfiles, Gemfiles.lock). I don't see the point "disabling gem updates" system-wide, whatever it means.

Bundle update uses our own gem repo, but it's not recommended using it. We could only remove the source "fedorahoste.org/repos/katello" line maybe, but I don't see much added value.

Not a bug?
Comment 2 Mike McCune 2012-05-15 12:13:57 EDT
I agree with Lukas, while 'gem update' could really screw up your CloudForms install there isn't a whole lot we can do to block this except for overriding the functionality contained within the rubygems package itself.

Since we rely on rubygems to resolve dependencies for our ruby packages I don't think we want to forcibly override the behaviour in this upstream package.

Going to close as WONTFIX but if you feel we really need to address this please re-open and we can raise the issue with a larger group.

Note You need to log in before you can comment on or make changes to this bug.