This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 820405 - [RFE] Can't edit product repository. Clicking the edit link only shows you the repo.
[RFE] Can't edit product repository. Clicking the edit link only shows you th...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 16:12 EDT by james labocki
Modified: 2014-09-18 11:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-08 14:29:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2012-05-09 16:12:49 EDT
Description of problem:
Can't edit product repository. Clicking the edit link only shows
you the repo.
Comment 1 Mike McCune 2012-07-11 11:24:57 EDT
we can't let users edit URLs or names of repos if you have synced them already but we can for new repos do:

1) let you edit unsynced repos (URL + name possibly if it isn't used in the ID)

2) Add a better help tip to point out what the URL should point at

3) Add validation to check the remote location to see if it is at least a valid path. I would hesitate to check if it is a valid repo since we may be doing various content types in the future
Comment 2 Bryan Kearney 2014-09-08 14:29:47 EDT
I believe the new UI makes this much better. I am going to close this out. If you disgaree, please free free to re-open

Note You need to log in before you can comment on or make changes to this bug.