Bug 820417 - --annotation option listed and accepted on incorrect wallaby shell commands
--annotation option listed and accepted on incorrect wallaby shell commands
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: wallaby-utils (Show other bugs)
Development
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: grid-maint-list
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 16:52 EDT by Robert Rati
Modified: 2016-05-26 16:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-26 16:20:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2012-05-09 16:52:07 EDT
Description of problem:
The --annotation option is listed and accepted on list-*, show-*, and remove-* wallaby shell commands.  The worse part is that those command accept the value and set the annotation:

wallaby show-node --annotation Hello node1
<node desc w/o annotation set>
wallaby show-node node1
...
  annotation:  "Hello"
...

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Martin Kudlej 2012-09-04 11:14:34 EDT
The problem is that user will not be able to set annotation with commands start with list-*, show-*, and remove-*.
Comment 4 Stanislav Graf 2014-03-05 04:22:28 EST
Wallaby references:
http://getwallaby.com/
https://github.com/getwallaby/wallaby

We are interested in:
1] propose patch that fixes the issue
2] propose new unittests or modification of already existing unittests that covers your changes (see GIT repository)
3] propose human testing scenario down to individual steps
4] automate testing scenario (from 3]) using python or java

In case you struggle you can:
- join IRC channel #distcomp on http://freenode.net/
- ask here in Bugzilla using comment field
- ask on mailing list http://lists.getwallaby.com/listinfo.cgi/dev-getwallaby.com
Comment 5 Anne-Louise Tangring 2016-05-26 16:20:37 EDT
MRG-Grid is in maintenance and only customer escalations will be considered. This issue can be reopened if a customer escalation associated with it occurs.

Note You need to log in before you can comment on or make changes to this bug.