Bug 820503 - cspclient rpm does not install on RHEL 5
cspclient rpm does not install on RHEL 5
Status: CLOSED WONTFIX
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 04:48 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-22 02:30:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-05-10 04:48:18 EDT
My error message is here: https://bugzilla.redhat.com/show_bug.cgi?id=820501

This looks like the solution: https://bugzilla.redhat.com/show_bug.cgi?id=665073

Requires building the rpm with some macros enabled...
Comment 1 Lee Newson 2012-05-19 19:37:49 EDT
Will take a look at this when I can get some time to setup a RHEL 5 test vm.
Comment 2 Misty Stanley-Jones 2013-05-28 22:33:14 EDT
I assume this is actually working now? If so, please close. :) Although, who is still using RHEL 5 here?
Comment 3 Lee Newson 2013-11-22 02:30:42 EST
I've added the following macros which should allow the RPM to be installed on RHEL 5:

%global _source_filedigest_algorithm 1
%global _binary_filedigest_algorithm 1
%global _binary_payload w9.gzdio
%global _source_payload w9.gzdio

However, RHEL 5 isn't something we have plans to support at this stage so I'm going to close this as WONTFIX. (I don't have a RHEL 5 system to test on and at this stage don't have the time to set one up).
Comment 4 Lee Newson 2013-11-22 02:34:44 EST
https://access.redhat.com/site/solutions/41415 is where I got the information on what macros should be set.

Note You need to log in before you can comment on or make changes to this bug.