Bug 820510 - RFE: Refer to server by short name
RFE: Refer to server by short name
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 05:14 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.24.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:29:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-05-10 05:14:05 EDT
Given an entry like this in ~/.config/csprocessor.ini:

#fedora
fedora.url=http://docs.fedorareloaded.com:8080/TopicIndex/
fedora.username=


Allow this to succeed:

[jwulf@nitai FUDCon_Docs_Hack_Instruction_Manual]$ csprocessor list -H fedora
CSProcessor client version: 0.23.2
Loading configuration from /home/jwulf/.config/csprocessor.ini
Connecting to Skynet server: http://fedora/

ERROR: Cannot connect to the server, as the server address can't be resolved.




cspclient-0.23.2-1.noarch
OS: Fedora release 16 (Verne)

JAVA: java version "1.7.0_b147-icedtea"
OpenJDK Runtime Environment (fedora-2.1.fc16.1-x86_64)
OpenJDK 64-Bit Server VM (build 22.0-b10, mixed mode)
Comment 1 Lee Newson 2012-05-10 18:55:08 EDT
I won't add this, at this stage because the -H switch is for when your connecting to a server that you wouldn't normally connect to and hence should use the full URL. If its one that you will be connecting to frequently then it should be setup in the csprocessor.ini or csprocessor.cfg file.
Comment 2 Joshua Wulf 2012-05-12 19:03:40 EDT
In the example I give above, the server *is* set up in the csprocessor.ini file.

The issue is that when I push a new content spec I have to give the csprocessor the whole URL, because it doesn't seem to look in the csprocessor.ini file for the entry. 

So I have to do:

csprocessor create -H http://docs.fedorareloaded.com:8080/TopicIndex intro-fedora.contentspec

Even though I have that URL set up in the csprocessor.ini as fedora.url.

Am I doing it wrong?

I think it should be:

csprocessor push -H fedora intro-fedora.contentspec

Right now that doesn't work:

[jwulf@radhe scratch]$ csprocessor create -H fedora intro-fedora.contentspec
CSProcessor client version: 0.23.2
Loading configuration from /home/jwulf/.config/csprocessor.ini
Connecting to Skynet server: http://fedora/

ERROR: Cannot connect to the server, as the server address can't be resolved.
Comment 3 Lee Newson 2012-05-15 03:06:11 EDT
Hmm, your right I had forgotten about the create/checkout method since it can't use either of the configuration files beside the default server. 

So the three options are make the user change the default server each time, specify the full URL when using the create command or the example you gave. I have to agree that the first two are painful and just plain ridiculous. So i'll change this back to assigned and update it once implemented.
Comment 4 Lee Newson 2012-05-18 06:45:12 EDT
Fixed in 0.24.0

You can now use the -H option and just specify the csprocessor server name rather then the full path.
Comment 5 Lee Newson 2013-06-06 21:29:32 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.