Bug 820520 - RFE: Setup Command should skip default server when only one exists
RFE: Setup Command should skip default server when only one exists
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 05:41 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.24.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:30:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-05-10 05:41:32 EDT
cspclient-0.23.2-1.noarch


csprocessor setup is killer!

One small thing: when I enter to accept the suggested default here, it doesn't act as expected, requiring me to type out the name before it will continue.

Which server do you want to connect to by default? (fedora)

Which server do you want to connect to by default? (fedora)

Which server do you want to connect to by default? (fedora)
fedora
Comment 1 Lee Newson 2012-05-10 18:37:49 EDT
Not a bug.

This is intended as it list all the possible server setups. You then have to select one of those. 

As such I'm turning this into an RFE so that when only one exists it will skip that question entirely.
Comment 2 Lee Newson 2012-05-18 06:44:02 EDT
Fixed in 0.24.0

You can now use the -H option and just specify the csprocessor server name rather then the full path.
Comment 3 Lee Newson 2012-05-18 06:46:29 EDT
Oops that comment was meant for a different bug.

Anyways it's still added in 0.24.0.

Now if there is only one server it will skip that question in the setup.
Comment 4 Joshua Wulf 2012-05-19 09:14:16 EDT
Have to doublecheck, but when I did the EC2 machine to test the RHEL6 xml mangling issue, I'm pretty sure 0.25 still:
* Prompted for a default during setup when only one server was being setup; 
* Refused to take it's own selection when I pressed enter, and made me laboriously type it out in front of it, humiliating me

(just went through customs ;-)
Comment 5 Lee Newson 2012-05-19 19:26:30 EDT
As stated it's updated in 0.24.0, which hasn't been released yet so of course it won't work on 0.23.5.
Comment 6 Lee Newson 2013-06-06 21:30:07 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.