Bug 820538 - Snowdrop: Missing EAP6 module org.jboss.interceptor
Snowdrop: Missing EAP6 module org.jboss.interceptor
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Spring (Show other bugs)
2.0.0.ER5
Unspecified Unspecified
urgent Severity urgent
: ---
: 2.0.0.ER6
Assigned To: Marius Bogoevici
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 06:30 EDT by Tomas Repel
Modified: 2013-03-03 20:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 03:32:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Repel 2012-05-10 06:30:01 EDT
Description of problem:

EAP6 ER6 doesn't contain org.jboss.interceptor module anymore. This module is required for org.jboss.snowdrop module. When using Snowdrop, the EAP6 throws error on startup.

Version-Release number of selected component (if applicable):

EAP6 ER6

How reproducible:

Always.

Steps to Reproduce:
1. Install Snowdrop module on EAP6 ER6
2. Run it
  
Actual results:

12:08:49,139 INFO  [org.jboss.modules] JBoss Modules version 1.1.1.GA-redhat-1
12:08:49,303 INFO  [org.jboss.msc] JBoss MSC version 1.0.2.GA-redhat-1
12:08:49,384 INFO  [org.jboss.as] JBAS015899: JBoss EAP 6.0.0.Beta2 (AS 7.1.1.Final-redhat-1) starting
12:08:49,810 ERROR [org.jboss.as.server] JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
	at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.as.server.ServerService.boot(ServerService.java:268) [jboss-as-server-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:155) [jboss-as-controller-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at java.lang.Thread.run(Thread.java:679) [rt.jar:1.6.0_22]
Caused by: javax.xml.stream.XMLStreamException: Failed to load module org.jboss.snowdrop
	at org.jboss.as.controller.parsing.ExtensionXml.parseExtensions(ExtensionXml.java:154) [jboss-as-controller-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_1(StandaloneXml.java:307) [jboss-as-server-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:128) [jboss-as-server-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:100) [jboss-as-server-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-1.jar:1.1.0.Final-redhat-1]
	at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final-redhat-1.jar:1.1.0.Final-redhat-1]
	at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:133) [jboss-as-controller-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	... 3 more
Caused by: java.util.concurrent.ExecutionException: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load module
	at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:252) [rt.jar:1.6.0_22]
	at java.util.concurrent.FutureTask.get(FutureTask.java:111) [rt.jar:1.6.0_22]
	at org.jboss.as.controller.parsing.ExtensionXml.parseExtensions(ExtensionXml.java:146) [jboss-as-controller-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	... 9 more
Caused by: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load module
	at org.jboss.as.controller.parsing.ExtensionXml.loadModule(ExtensionXml.java:195) [jboss-as-controller-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.as.controller.parsing.ExtensionXml.access$000(ExtensionXml.java:68) [jboss-as-controller-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java:126) [jboss-as-controller-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java:123) [jboss-as-controller-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) [rt.jar:1.6.0_22]
	at java.util.concurrent.FutureTask.run(FutureTask.java:166) [rt.jar:1.6.0_22]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.6.0_22]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.6.0_22]
	at java.lang.Thread.run(Thread.java:679) [rt.jar:1.6.0_22]
	at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.0.0.GA-redhat-1.jar:2.0.0.GA-redhat-1]
Caused by: org.jboss.modules.ModuleNotFoundException: Module org.jboss.interceptor:main is not found in local module loader @15f66cff (roots: /home/trepel/sources/jboss-eap-6.0/modules)
	at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:126) [jboss-modules.jar:1.1.1.GA-redhat-1]
	at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275) [jboss-modules.jar:1.1.1.GA-redhat-1]
	at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jboss-modules.jar:1.1.1.GA-redhat-1]
	at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:94) [jboss-modules.jar:1.1.1.GA-redhat-1]
	at org.jboss.modules.Module.addPaths(Module.java:841) [jboss-modules.jar:1.1.1.GA-redhat-1]
	at org.jboss.modules.Module.link(Module.java:1181) [jboss-modules.jar:1.1.1.GA-redhat-1]
	at org.jboss.modules.Module.relinkIfNecessary(Module.java:1207) [jboss-modules.jar:1.1.1.GA-redhat-1]
	at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208) [jboss-modules.jar:1.1.1.GA-redhat-1]
	at org.jboss.as.controller.parsing.ExtensionXml.loadModule(ExtensionXml.java:177) [jboss-as-controller-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	... 9 more

12:08:49,835 FATAL [org.jboss.as.server] JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details.
12:08:49,861 INFO  [org.jboss.as] JBAS015950: JBoss EAP 6.0.0.Beta2 (AS 7.1.1.Final-redhat-1) stopped in 20ms


Expected results:

EAP6 ER6 starts correctly.

Additional info:

The EAP6 ER5 contains module org.jboss.interceptor, thus it works correctly.
Comment 3 Marius Bogoevici 2012-05-10 09:19:22 EDT
I think that removing 

            <module name="org.jboss.interceptor"/>
            <module name="org.jboss.interceptor.spi"/>

from the module.xml files will solve this.
Comment 4 Tomas Repel 2012-05-10 10:25:09 EDT
The 

<module name="org.jboss.interceptor"/>
<module name="org.jboss.interceptor.spi"/>

modules have to be removed from modules/org/springframework/spring/snowdrop/module.xml too.
Comment 5 Karel Piwko 2012-05-10 15:21:46 EDT
Marius, so modules are not needed for any Snowdrop functionality?
Comment 6 Marius Bogoevici 2012-05-11 10:49:44 EDT
No, that is correct.
Comment 7 Marek Novotny 2012-05-23 06:52:18 EDT
cherry picked the fix from upstream project - http://git.app.eng.bos.redhat.com/?p=snowdrop/snowdrop.git;a=commit;h=e01e9d39ff926e75e3ae2157bd75e550ee269238
Comment 8 Tomas Repel 2012-05-25 05:21:17 EDT
Verified in WFK2 ER6.

Note You need to log in before you can comment on or make changes to this bug.