This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 820541 - declare conflict with vdsm < 4.9-113.0
declare conflict with vdsm < 4.9-113.0
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Peter Rajnoha
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 06:54 EDT by Dan Kenigsberg
Modified: 2012-06-20 11:03 EDT (History)
16 users (show)

See Also:
Fixed In Version: lvm2-2.02.95-9.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:03:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Kenigsberg 2012-05-10 06:54:40 EDT
Description of problem:
lvm2-2.02.95 reports two new LV attribute bits (target, zero) relative to rhel-6.2's lvm2-2.02.87. This is known to break vdsm-4.9-112 from rhev-3.0 (see bug 820525). rhev-3.0 customers who would happen to upgrade their lvm2 but keep their vdsm, are going to render their rhev node useless. Please add

Conflicts: vdsm < 4.9-113.0

to lvm2 spec to avoid this.

Version-Release number of selected component (if applicable):
lvm2-2.02.95

How reproducible:
always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alasdair Kergon 2012-05-10 08:08:53 EDT
We can do this on this one occasion, but please make sure that next time we append characters to this field for new features, vdsm ignores the new characters and does not need updating like this again.
Comment 3 Alasdair Kergon 2012-05-10 20:47:07 EDT
(Also note that my comment applies to all 3 *_attr fields - PV, LV and VG.)
Comment 7 Corey Marthaler 2012-05-16 16:28:59 EDT
Marking verified (SanityOnly),
Comment 8 Peter Rajnoha 2012-05-22 05:30:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 10 errata-xmlrpc 2012-06-20 11:03:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0962.html

Note You need to log in before you can comment on or make changes to this bug.