Bug 820577 - few actions in UserPortal failed due to user query permissions error
few actions in UserPortal failed due to user query permissions error
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Allon Mureinik
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 08:17 EDT by Avihai Shoham
Modified: 2012-12-17 02:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-17 02:48:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine_log_use_case2.log (748.33 KB, application/octet-stream)
2012-05-10 08:18 EDT, Avihai Shoham
no flags Details
engine_log_use_case1.log (1006.47 KB, application/octet-stream)
2012-05-10 08:18 EDT, Avihai Shoham
no flags Details

  None (edit)
Description Avihai Shoham 2012-05-10 08:17:51 EDT
i found two cases in User Portal that failed due to "Query execution failed due to insufficient permissions"

Use case 1 : when trying to login using UserPortal I'm getting  "User already logged in" message . therefore i cannot login 
Use case 2 : when trying to add disk via UserPortal the action failed.

as i understand :
use case1  should be resolved in commit d545a70aa11b4e6222a0d5e63be266c5c80735fa
use case2 should be resolved in a patch http://gerrit.ovirt.org/#change,4268
 
i have both fixes and i still getting these failures.

Pls see below the engine logs for both cases


use case 1
-----------
2012-05-08 18:10:00,004 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-52) Checking autorecoverable storage domains
2012-05-08 18:10:00,006 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-52) Checking autorecoverable storage domains done
2012-05-08 18:12:56,590 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-1) calling GetConfigurationValueQuery (ProductRPMVersion) with null version, using default general for version
2012-05-08 18:13:08,687 INFO  [org.ovirt.engine.core.bll.LoginUserCommand] (http--0.0.0.0-8080-1) [53ae9f39] Checking if user rgolan is an admin, result false
2012-05-08 18:13:08,689 INFO  [org.ovirt.engine.core.bll.LoginUserCommand] (http--0.0.0.0-8080-1) [53ae9f39] Running command: LoginUserCommand internal: false.
2012-05-08 18:13:08,772 ERROR [org.ovirt.engine.core.bll.GetUserBySessionIdQuery] (http--0.0.0.0-8080-1) Query execution failed due to insufficient permissions.
2012-05-08 18:14:11,621 WARN  [org.ovirt.engine.core.bll.LoginUserCommand] (http--0.0.0.0-8080-8) [4596357f] CanDoAction of action LoginUser failed. Reasons:USER_IS_ALREADY_LOGGED_IN
2012-05-08 18:14:12,022 WARN  [org.ovirt.engine.core.bll.LoginUserCommand] (http--0.0.0.0-8080-2) [4ae98c2] CanDoAction of action LoginUser failed. Reasons:USER_IS_ALREADY_LOGGED_IN


use case 2
-------------
2012-05-10 17:04:33,876 WARN  [org.ovirt.engine.core.bll.GetConfigurationValueQuery] (http--0.0.0.0-8080-3) calling GetConfigurationValueQuery (MaxDiskSize) with null version, using default general for version
2012-05-10 17:04:33,974 ERROR [org.ovirt.engine.core.bll.GetDiskConfigurationListQuery] (http--0.0.0.0-8080-3) Query execution failed due to insufficient permissions.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Avihai Shoham 2012-05-10 08:18:34 EDT
Created attachment 583526 [details]
engine_log_use_case2.log
Comment 2 Avihai Shoham 2012-05-10 08:18:56 EDT
Created attachment 583528 [details]
engine_log_use_case1.log
Comment 3 Allon Mureinik 2012-05-13 10:24:07 EDT
Re: usecase 1 - I tried logging into the Power User Portal regularly, with two different firefox tabs, with two separate firefox windows, and after kill -9 to my firefox; and I am still unable to reproduce the behavior.
(commit hash b272a1e24f9f30f6d72a27796a51ecebbba92711)

Please advise how to reproduce it.
Comment 4 Allon Mureinik 2012-05-13 11:57:32 EDT
Re usecase 2 - submitted a patch to gerrit, still pending review:
http://gerrit.ovirt.org/#change,4381
Comment 5 Allon Mureinik 2012-05-14 09:26:46 EDT
usecase 1 - was due to an environment issue, does not reproduce anymore.
Comment 6 Allon Mureinik 2012-05-20 04:04:19 EDT
Patch was merged.
Comment 7 Avihai Shoham 2012-05-22 10:26:42 EDT
verified on dev env last commit 72d1d5c1902a5c005d9b6bd2227dea95260286d1

Note You need to log in before you can comment on or make changes to this bug.