Bug 820639 - subscription-manager release --list should exclude listings from disabled repos
subscription-manager release --list should exclude listings from disabled repos
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-05-10 10:52 EDT by John Sefler
Modified: 2012-06-20 08:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:57:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-05-10 10:52:35 EDT
Description of problem:
After subscribing to a RHEL subscription, a call to subscription-manager release --list will show you all the possible $releasever values that you can set so as to limit your content to a particular path for the entitled repos.  However not all repos are enabled and therefore the available release list should only show valid $releasever that are applicable to the currently enable repos otherwise you will get PYCURL ERROR 22 - "The requested URL returned error: 404" when running yum.


Version-Release number of selected component (if applicable):
[root@qe-blade-13 ~]# rpm -q subscription-manager
subscription-manager-0.99.17-1.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@qe-blade-13 ~]# subscription-manager config --server.hostname subscription.rhn.stage.redhat.com
[root@qe-blade-13 ~]# subscription-manager config --rhsm.baseurl=https://cdn.rcm-qa.redhat.com
[root@qe-blade-13 ~]# subscription-manager register --username stage_test_12 --autosubscribe
Password: 
The system has been registered with id: 650d992b-801d-495d-a98d-d37217923e85 
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed               

[root@qe-blade-13 ~]# subscription-manager release --list
6.1
6.2
6.3
6Server
[root@qe-blade-13 ~]# 

^^^ NOTICE THE AVAILABLE RELEASE INCLUDE 6.3, LET'S SET IT AND SEE WHAT HAPPENS...

[root@qe-blade-13 ~]# subscription-manager release --set 6.3
Release set to: 6.3
[root@qe-blade-13 ~]# yum -q repolist
https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/x86_64/cf-tools/1.0/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/x86_64/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/x86_64/devtoolset/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
[root@qe-blade-13 ~]# 

^^^ NOTICE THE 404 ERRORS ON PATHS https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/x86_64...

THIS IS CAUSED BECAUSE THE 6.3 IS GETTING PULLED FROM A CDN LISTING OF CONTENT THAT IS NOT ACTUALLY ENABLED...

[root@qe-blade-13 ~]# curl --stderr /dev/null --insecure --cert /etc/pki/entitlement/2013167262444796312.pem --key /etc/pki/entitlement/2013167262444796312-key.pem https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/listing
6.1
6.2
6.3
6Server

[root@qe-blade-13 ~]# curl --stderr /dev/null --insecure --cert /etc/pki/entitlement/201316726244479m --key /etc/pki/entitlement/2013167262444796312-key.pem https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/listing
6.1
6.2
6Server

[root@qe-blade-13 ~]# subscription-manager repos --list
+----------------------------------------------------------+
    Entitled Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo Name:            	Red Hat Subscription Asset Manager (for RHEL 6 Server) (Source RPMs)
Repo Id:              	rhel-6-server-sam-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/subscription-asset-manager/1/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat CloudForms Tools for RHEL 6 (Source RPMs)
Repo Id:              	rhel-6-server-cf-tools-1-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/cf-tools/1.0/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server (RPMs)
Repo Id:              	rhel-6-server-rpms       
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/os
Enabled:              	1                        

Repo Name:            	Red Hat CloudForms Tools for RHEL 6 Beta (RPMs)
Repo Id:              	rhel-6-server-cf-tools-1-beta-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/cf-tools/1.0/os
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server (Source RPMs)
Repo Id:              	rhel-6-server-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat Developer Toolset Beta Debug RPMs for Red Hat Enterprise Linux 6 Server
Repo Id:              	rhel-server-dts-6-beta-debug-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/devtoolset/debug
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server Beta (Source RPMs)
Repo Id:              	rhel-6-server-beta-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Optional (Debug RPMs)
Repo Id:              	rhel-6-server-optional-debug-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/optional/debug
Enabled:              	0                        

Repo Name:            	Red Hat CloudForms Tools for RHEL 6 (Debug RPMs)
Repo Id:              	rhel-6-server-cf-tools-1-debug-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/cf-tools/1.0/debug
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server (Debug RPMs)
Repo Id:              	rhel-6-server-debug-rpms 
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/debug
Enabled:              	0                        

Repo Name:            	Red Hat Developer Toolset Source RPMs for Red Hat Enterprise Linux 6 Server
Repo Id:              	rhel-server-dts-6-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/devtoolset/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Optional Beta (Debug RPMs)
Repo Id:              	rhel-6-server-optional-beta-debug-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/optional/debug
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Supplementary (Debug RPMs)
Repo Id:              	rhel-6-server-supplementary-debuginfo
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/supplementary/debug
Enabled:              	0                        

Repo Name:            	Red Hat Developer Toolset Beta RPMs for Red Hat Enterprise Linux 6 Server
Repo Id:              	rhel-server-dts-6-beta-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/devtoolset/os
Enabled:              	0                        

Repo Name:            	Red Hat CloudForms Tools for RHEL 6 Beta (Source RPMs)
Repo Id:              	rhel-6-server-cf-tools-1-beta-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/cf-tools/1.0/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat Subscription Asset Manager (for RHEL 6 Server) Beta (Debug RPMs)
Repo Id:              	rhel-6-server-sam-beta-debug-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/subscription-asset-manager/debug
Enabled:              	0                        

Repo Name:            	Red Hat Subscription Asset Manager (for RHEL 6 Server) (Debug RPMs)
Repo Id:              	rhel-6-server-sam-debug-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/subscription-asset-manager/1/debug
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Supplementary Beta (RPMs)
Repo Id:              	rhel-6-server-supplementary-beta-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/supplementary/os
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Optional Beta (Source RPMs)
Repo Id:              	rhel-6-server-optional-beta-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/optional/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Supplementary (Source RPMs)
Repo Id:              	rhel-6-server-supplementary-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/supplementary/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Supplementary Beta (Debug RPMs)
Repo Id:              	rhel-6-server-supplementary-beta-debuginfo
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/supplementary/debug
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Optional (Source RPMs)
Repo Id:              	rhel-6-server-optional-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/optional/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Optional Beta (RPMs)
Repo Id:              	rhel-6-server-optional-beta-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/optional/os
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server Beta (RPMs)
Repo Id:              	rhel-6-server-beta-rpms  
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/os
Enabled:              	0                        

Repo Name:            	Red Hat Developer Toolset Beta Source RPMs for Red Hat Enterprise Linux 6 Server
Repo Id:              	rhel-server-dts-6-beta-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/devtoolset/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat Developer Toolset Debug RPMs for Red Hat Enterprise Linux 6 Server
Repo Id:              	rhel-server-dts-6-debug-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/devtoolset/debug
Enabled:              	0                        

Repo Name:            	Red Hat Subscription Asset Manager (for RHEL 6 Server) (RPMs)
Repo Id:              	rhel-6-server-sam-rpms   
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/subscription-asset-manager/1/os
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Optional (RPMs)
Repo Id:              	rhel-6-server-optional-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/optional/os
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Supplementary Beta (Source RPMs)
Repo Id:              	rhel-6-server-supplementary-beta-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/supplementary/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server Beta (Debug RPMs)
Repo Id:              	rhel-6-server-beta-debug-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/debug
Enabled:              	0                        

Repo Name:            	Red Hat Subscription Asset Manager (for RHEL 6 Server) Beta (RPMs)
Repo Id:              	rhel-6-server-sam-beta-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/subscription-asset-manager/os
Enabled:              	0                        

Repo Name:            	Red Hat CloudForms Tools for RHEL 6 (RPMs)
Repo Id:              	rhel-6-server-cf-tools-1-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/cf-tools/1.0/os
Enabled:              	1                        

Repo Name:            	Red Hat Subscription Asset Manager (for RHEL 6 Server) Beta (Source RPMs)
Repo Id:              	rhel-6-server-sam-beta-source-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/subscription-asset-manager/source/SRPMS
Enabled:              	0                        

Repo Name:            	Red Hat Enterprise Linux 6 Server - Supplementary (RPMs)
Repo Id:              	rhel-6-server-supplementary-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/supplementary/os
Enabled:              	0                        

Repo Name:            	Red Hat Developer Toolset RPMs for Red Hat Enterprise Linux 6 Server
Repo Id:              	rhel-server-dts-6-rpms   
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.3/$basearch/devtoolset/os
Enabled:              	1                        

Repo Name:            	Red Hat CloudForms Tools for RHEL 6 Beta (Debug RPMs)
Repo Id:              	rhel-6-server-cf-tools-1-beta-debug-rpms
Repo Url:             	https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/6.3/$basearch/cf-tools/1.0/debug
Enabled:              	0                        

[root@qe-blade-13 ~]# 

^^^ NOTICE THAT 6.3 WAS SUBSTITUTED INTO ALL $releasever VARIABLES IN THE REPO URLS AND SINCE THE VALUE OF 6.3 CAME FROM A CDN REPO URL PATH THAT WAS ACTUALLY DISABLED, THEN IT BREAKS THE PATH TO THE ENABLED REPO URLS.

SETTING RELEASE TO A VALUE FROM AN ENABLED CDN LISTING WILL NOT THROW ANY PYCURL 404 ERRORS...

[root@qe-blade-13 ~]# subscription-manager release --set 6.2
Release set to: 6.2
[root@qe-blade-13 ~]# yum -q repolist
[root@qe-blade-13 ~]#

  
SOLUTION IS TO EXCLUDE DISABLED REPOS WHEN CONSOLIDATING THE CDN LISTING FOR $releasever
Comment 2 Adrian Likins 2012-05-11 11:15:03 EDT
commit 7aae2f57b9cc68c18105c3eb3ffb05f13f34942c
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu May 10 17:03:28 2012 -0400

    820639: Don't show unenabled content as an available release
    
    For beta's and the like, we could have content associated
    with an entitlment that includes a release 'listing',
    but the content itself isn't enabled, so the resulting
    yum url is wrong.

should be in 0.99.18
Comment 6 John Sefler 2012-05-18 11:24:45 EDT
Verifying Version...
[root@qe-blade-06 ~]# rpm -q subscription-manager
subscription-manager-0.99.18-1.el6.x86_64


[root@qe-blade-06 ~]# subscription-manager config --server.hostname subscription.rhn.stage.redhat.com
[root@qe-blade-06 ~]# subscription-manager config --rhsm.baseurl=https://cdn.rcm-qa.redhat.com
[root@qe-blade-06 ~]# subscription-manager register --autosubscribe --username stage_test_12 
Password: 
The system has been registered with id: 004dfcd8-3d3e-462e-b69c-5f190003c865 
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed               

[root@qe-blade-06 ~]# subscription-manager release --list
6.1
6.2
6Server
[root@qe-blade-06 ~]# 

^^^ THAT LIST IS LOOKING GOOD., LET'S ASSERT THIS LISTING CAME FROM THE ENABLED REPOS...


[root@qe-blade-06 ~]# yum repolist enabled
Loaded plugins: product-id, refresh-packagekit, security, subscription-
              : manager
Updating certificate-based repositories.
rhel-6-server-cf-tools-1-rpms                         | 2.6 kB     00:00     
rhel-6-server-rpms                                    | 3.7 kB     00:00     
rhel-server-dts-6-rpms                                | 2.5 kB     00:00     
repo id                       repo name                                status
rhel-6-server-cf-tools-1-rpms Red Hat CloudForms Tools for RHEL 6 (RPM    25
rhel-6-server-rpms            Red Hat Enterprise Linux 6 Server (RPMs) 7,236
rhel-server-dts-6-rpms        Red Hat Developer Toolset RPMs for Red H     0
repolist: 7,261
[root@qe-blade-06 ~]# 


VERIFYING THE FIRST ENABLED REPO rhel-6-server-cf-tools-1-rpms...
[root@qe-blade-06 ~]# cat /etc/yum.repos.d/redhat.repo | grep rhel-6-server-cf-tools-1-rpms -A3
[rhel-6-server-cf-tools-1-rpms]
name = Red Hat CloudForms Tools for RHEL 6 (RPMs)
baseurl = https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/cf-tools/1.0/os
enabled = 1
[root@qe-blade-06 ~]# curl --stderr /dev/null --insecure --cert /etc/pki/entitlement/4211016517268981194.pem --key /etc/pki/entitlement/4211016517268981194-key.pem  https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/listing
6.1
6.2
6Server[root@qe-blade-06 ~]# 

VERIFYING THE SECOND ENABLED REPO rhel-6-server-cf-tools-1-rpms...
[root@qe-blade-06 ~]# cat /etc/yum.repos.d/redhat.repo | grep rhel-6-server-rpms -A3
[rhel-6-server-rpms]
name = Red Hat Enterprise Linux 6 Server (RPMs)
baseurl = https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/os
enabled = 1
[root@qe-blade-06 ~]# curl --stderr /dev/null --insecure --cert /etc/pki/entitlement/4211016517268981194.pem --key /etc/pki/entitlement/4211016517268981194-key.pem  https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/listing
6.1
6.2
6Server[root@qe-blade-06 ~]# 

VERIFYING THE THIRD ENABLED REPO rhel-server-dts-6-rpms...
[root@qe-blade-06 ~]# cat /etc/yum.repos.d/redhat.repo | grep rhel-server-dts-6-rpms -A3
[rhel-server-dts-6-rpms]
name = Red Hat Developer Toolset RPMs for Red Hat Enterprise Linux 6 Server
baseurl = https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/devtoolset/os
enabled = 1
[root@qe-blade-06 ~]# curl --stderr /dev/null --insecure --cert /etc/pki/entitlement/4211016517268981194.pem --key /etc/pki/entitlement/4211016517268981194-key.pem  https://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/listing
6.1
6.2
6Server[root@qe-blade-06 ~]# 


THE subscription-manager release --list INCLUDES ONLY VALUES FROM ALL THREE ENABLED REPOS LISTING.  THIS IS GOOD.


LET'S SHOW A LISTING FROM A DISABLED REPO IS EXCLUDED...
[root@qe-blade-06 ~]# yum repolist disabled
Loaded plugins: product-id, refresh-packagekit, security, subscription-
              : manager
Updating certificate-based repositories.
repo id                                      repo name                       
beaker-HighAvailability                      beaker-HighAvailability         
beaker-LoadBalancer                          beaker-LoadBalancer             
beaker-ResilientStorage                      beaker-ResilientStorage         
beaker-ScalableFileSystem                    beaker-ScalableFileSystem       
beaker-Server                                beaker-Server                   
beaker-debug                                 beaker-debug                    
beaker-harness                               beaker-harness                  
beaker-optional-x86_64-debug                 beaker-optional-x86_64-debug    
beaker-optional-x86_64-os                    beaker-optional-x86_64-os       
beaker-tasks                                 beaker-tasks                    
ldtp                                         Linux Desktop Testing Project (R
rhel-6-server-beta-debug-rpms                Red Hat Enterprise Linux 6 Serve
rhel-6-server-beta-rpms                      Red Hat Enterprise Linux 6 Serve
rhel-6-server-beta-source-rpms               Red Hat Enterprise Linux 6 Serve
rhel-6-server-cf-tools-1-beta-debug-rpms     Red Hat CloudForms Tools for RHE
rhel-6-server-cf-tools-1-beta-rpms           Red Hat CloudForms Tools for RHE
rhel-6-server-cf-tools-1-beta-source-rpms    Red Hat CloudForms Tools for RHE
rhel-6-server-cf-tools-1-debug-rpms          Red Hat CloudForms Tools for RHE
rhel-6-server-cf-tools-1-source-rpms         Red Hat CloudForms Tools for RHE
rhel-6-server-debug-rpms                     Red Hat Enterprise Linux 6 Serve
rhel-6-server-optional-beta-debug-rpms       Red Hat Enterprise Linux 6 Serve
rhel-6-server-optional-beta-rpms             Red Hat Enterprise Linux 6 Serve
rhel-6-server-optional-beta-source-rpms      Red Hat Enterprise Linux 6 Serve
rhel-6-server-optional-debug-rpms            Red Hat Enterprise Linux 6 Serve
rhel-6-server-optional-rpms                  Red Hat Enterprise Linux 6 Serve
rhel-6-server-optional-source-rpms           Red Hat Enterprise Linux 6 Serve
rhel-6-server-sam-beta-debug-rpms            Red Hat Subscription Asset Manag
rhel-6-server-sam-beta-rpms                  Red Hat Subscription Asset Manag
rhel-6-server-sam-beta-source-rpms           Red Hat Subscription Asset Manag
rhel-6-server-sam-debug-rpms                 Red Hat Subscription Asset Manag
rhel-6-server-sam-rpms                       Red Hat Subscription Asset Manag
rhel-6-server-sam-source-rpms                Red Hat Subscription Asset Manag
rhel-6-server-source-rpms                    Red Hat Enterprise Linux 6 Serve
rhel-6-server-supplementary-beta-debuginfo   Red Hat Enterprise Linux 6 Serve
rhel-6-server-supplementary-beta-rpms        Red Hat Enterprise Linux 6 Serve
rhel-6-server-supplementary-beta-source-rpms Red Hat Enterprise Linux 6 Serve
rhel-6-server-supplementary-debuginfo        Red Hat Enterprise Linux 6 Serve
rhel-6-server-supplementary-rpms             Red Hat Enterprise Linux 6 Serve
rhel-6-server-supplementary-source-rpms      Red Hat Enterprise Linux 6 Serve
rhel-server-dts-6-beta-debug-rpms            Red Hat Developer Toolset Beta D
rhel-server-dts-6-beta-rpms                  Red Hat Developer Toolset Beta R
rhel-server-dts-6-beta-source-rpms           Red Hat Developer Toolset Beta S
rhel-server-dts-6-debug-rpms                 Red Hat Developer Toolset Debug 
rhel-server-dts-6-source-rpms                Red Hat Developer Toolset Source
rhel-source                                  Red Hat Enterprise Linux 6Server
rhel-source-beta                             Red Hat Enterprise Linux 6Server
repolist: 0
[root@qe-blade-06 ~]# cat /etc/yum.repos.d/redhat.repo | grep -A3 rhel-6-server-beta-rpms
[rhel-6-server-beta-rpms]
name = Red Hat Enterprise Linux 6 Server Beta (RPMs)
baseurl = https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/os
enabled = 0
[root@qe-blade-06 ~]# curl --stderr /dev/null --insecure --cert /etc/pki/entitlement/4211016517268981194.pem --key /etc/pki/entitlement/4211016517268981194-key.pem  https://cdn.rcm-qa.redhat.com/content/beta/rhel/server/6/listing
6.1
6.2
6.3
6Server[root@qe-blade-06 ~]# 

^^^ VERIFIED: DISABLED REPO rhel-6-server-beta-rpms INCLUDES A LISTING RELEASE "6.3" THAT IS NOT INCLUDED IN THE subscription-manager release --list.  THIS IS GOOD (AND WAS FIXED BY COMMENT 2).

Moving to VERIFIED.
Comment 9 errata-xmlrpc 2012-06-20 08:57:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.