Bug 820645 - wrong order in moving storage
wrong order in moving storage
Status: CLOSED DUPLICATE of bug 753549
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Ayal Baron
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 11:03 EDT by Pieter Vogel
Modified: 2016-02-10 12:08 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-16 15:36:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the move process out of the vdsm.log (434.40 KB, application/octet-stream)
2012-05-10 11:03 EDT, Pieter Vogel
no flags Details
complete log (1.95 MB, application/x-compressed-tar)
2012-05-10 11:05 EDT, Pieter Vogel
no flags Details

  None (edit)
Description Pieter Vogel 2012-05-10 11:03:34 EDT
Created attachment 583603 [details]
the move process out of the vdsm.log

Description of problem:
virtual machine with two disks in rhev (which I migrated from 2.2 to 3.0) Machine is in 3.0 hypervisor but storage was on old domain. After starting a storage move in webadmin it failed. (hypervisor crashed) Virtual machine was not bootable anymore.

It was not bootable because:
1 disk one is correctly moved
2 disk two is correctly moved
3 old disk1 is zero-ed
4 crash (I don't know why this happened but that is not important for this bug) 
5 virtual machine is still pointing to old disk location which does not exist anymore.

Version-Release number of selected component (if applicable):
rhev2.2 and rhev3.0 which rhev3.0 manager

  
Actual results:
virtual machine not bootable anymore (Exit message Bad volume specification)

Expected results:
virtual machine boots from new storage

Additional info:
after step 2 rhev should first point virtual machine to new storage location and then it may start writing zero's to old disk.

I fixed my machine by editing machine info in rhevm-database and then starting the virtual machine. That worked because moving storage did finish correct. writing zeros failed. (or it failed shortly after writing zeros)
Comment 1 Pieter Vogel 2012-05-10 11:05:43 EDT
Created attachment 583605 [details]
complete log
Comment 3 RHEL Product and Program Management 2012-05-14 00:04:44 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 04:55:13 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 21:55:50 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 RHEL Product and Program Management 2012-12-14 03:54:09 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 Ayal Baron 2013-02-16 15:36:17 EST
rhev 3.1 supports disks on different storage domains so this should be better now (many things have been fixed).
But the real solution for this is splitting move into copy and delete.

*** This bug has been marked as a duplicate of bug 753549 ***

Note You need to log in before you can comment on or make changes to this bug.