Bug 820662 - ldconfig does not configure shared libraries
ldconfig does not configure shared libraries
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sblim-cmpi-dhcp (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vitezslav Crhonek
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 11:35 EDT by Roman Rakus
Modified: 2017-12-06 05:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 05:23:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Rakus 2012-05-10 11:35:35 EDT
Description of problem:
Looks like you need to configure which paths should ldconfig traverse.


Version-Release number of selected component (if applicable):
sblim-cmpi-dhcp-1.0-1.el6.x86_64

How reproducible:
On 1st installation it was OK, but after few uninstalling and installing one library wasn't correctly linked

Steps to Reproduce:
1.# ldd /usr/lib64/cmpi/libcmpiLinux_DHCPGroup.so
  
Actual results:
        linux-vdso.so.1 =>  (0x00007fff4bdff000)
        libRaToolsDhcp.so.0 => /usr/lib64/libRaToolsDhcp.so.0 (0x00007fcc400fb000)
        libRaTools.so.0 => /usr/lib64/libRaTools.so.0 (0x00007fcc3fef7000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fcc3fb55000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fcc3f939000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003f06c00000)
        libuniquekey.so => not found

Expected results:
]# ldd /usr/lib64/cmpi/libcmpiLinux_DHCPGroup.so
        linux-vdso.so.1 =>  (0x00007fff7b5ff000)
        libRaToolsDhcp.so.0 => /usr/lib64/libRaToolsDhcp.so.0 (0x00007fc0be271000)
        libRaTools.so.0 => /usr/lib64/libRaTools.so.0 (0x00007fc0be06d000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fc0bdccb000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fc0bdaaf000)
        libuniquekey.so => /usr/lib64/cmpi/libuniquekey.so (0x00007fc0bd8ac000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003f06c00000)


Additional info:
I don't know which package should be the right one. Maybe tog-pegasus. But definitely there should be some file in /etc/ld.so.conf.d/. I have created /etc/ld.so.conf.d/cmpi.conf.
# cat /etc/ld.so.conf.d/cmpi.conf
/usr/lib64/cmpi/
Comment 2 RHEL Product and Program Management 2012-09-07 01:07:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Jan Kurik 2017-12-06 05:23:11 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.