Bug 820771 - from fresh install, httpd fails to serve beaker-server.wsgi due to missing dependency on isodate
from fresh install, httpd fails to serve beaker-server.wsgi due to missing de...
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.9
All Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Raymond Mancy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 19:30 EDT by Nish Aravamudan
Modified: 2015-05-03 22:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 01:06:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nish Aravamudan 2012-05-10 19:30:48 EDT
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31] mod_wsgi (pid=24158): Exception occurred processing WSGI script '/usr/share/bkr/beaker-server.wsgi'.
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31] Traceback (most recent call last):
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31]   File "/usr/share/bkr/beaker-server.wsgi", line 28, in <module>
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31]     import bkr.server.controllers
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31]   File "/usr/lib/python2.6/site-packages/bkr/server/controllers.py", line 67, in <module>
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31]     import bkr.server.rdf
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31]   File "/usr/lib/python2.6/site-packages/bkr/server/rdf.py", line 21, in <module>
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31]     from rdflib.namespace import Namespace, RDF, RDFS, XSD
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31]   File "/usr/lib/python2.6/site-packages/rdflib/__init__.py", line 65, in <module>
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31]     from rdflib.term import URIRef, BNode, Literal, Variable
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31]   File "/usr/lib/python2.6/site-packages/rdflib/term.py", line 49, in <module>
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31]     from isodate import parse_time, parse_date, parse_datetime
[Thu May 10 11:28:24 2012] [error] [client 9.65.33.31] ImportError: No module named isodate
Comment 1 Dan Callaghan 2012-05-30 01:06:42 EDT
It looks like you probably have EPEL enabled. It's a bug in python-rdflib (bug 784027).

I've pushed python-rdflib-3.2.0-4.el6eng to the Beaker server repo which fixes this.

Note You need to log in before you can comment on or make changes to this bug.