Bug 820883 - Stage and Prod can not be in logged in status at the same time
Stage and Prod can not be in logged in status at the same time
Status: CLOSED CANTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 06:01 EDT by Xiaoli Tian
Modified: 2015-05-14 21:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-11 11:37:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Development.log in devenv-stage server for scenario1 (18.42 KB, text/x-log)
2012-05-11 06:04 EDT, Xiaoli Tian
no flags Details
Development.log in devenv-stage server for scenario2 (16.00 KB, text/x-log)
2012-05-11 06:05 EDT, Xiaoli Tian
no flags Details

  None (edit)
Description Xiaoli Tian 2012-05-11 06:01:22 EDT
Description of problem:
If log into prod, and then log into stage, after refresh the prod tab, the users in prod and stage will be logged out.

Or if log into stage firstly and then log into prod in another tab, and refresh stage tab, user in stage is logged out.


Version-Release number of selected component (if applicable):
stage-2.0.11
devenv_193

How reproducible:
Always

Steps to Reproduce:
All the following are on the same browser, and stage could be replaced with devenv-stage-193

Scenario 1:

1. Open prod in one tab (tab 1), and open stage at another tab (tab 2);

2. Log into prod  with account 1 firstly- success

3. Log into stage  with account 2 - success

4. Refresh tab 1 -  user in prod is logged out and redirected back to home page.


Scenario 2: (Log into stage firstly):
1. Clear all cookies

2. Open stage in one tab (tab), and open prod at another tab (tab 2) :

1. Log into stage firsly - success

2. log into prod - success

3. Refresh stage prod, user in stage is logged out and show the log out information

  
Actual results:

Can not log in stage and prod at the same time

Expected results:
There should be no conflicts.

Additional info:
Please see attachment below
Comment 1 Xiaoli Tian 2012-05-11 06:04:54 EDT
Created attachment 583791 [details]
Development.log in devenv-stage server for  scenario1


Not sure if this bug is related to bug https://bugzilla.redhat.com/show_bug.cgi?id=817627
Comment 2 Xiaoli Tian 2012-05-11 06:05:27 EDT
Created attachment 583792 [details]
Development.log in devenv-stage server for  scenario2
Comment 4 Clayton Coleman 2012-05-11 11:37:55 EDT
You can't be logged in to stage and production at the same time because they share the rh_sso cookie (by design).

Note You need to log in before you can comment on or make changes to this bug.