This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 82089 - [cdrecord] Shows debug-output while burning
[cdrecord] Shows debug-output while burning
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: cdrtools (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-17 07:55 EST by Enrico Scholz
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 07:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Disables unwanted debug-output (464 bytes, patch)
2004-09-21 19:02 EDT, Enrico Scholz
no flags Details | Diff

  None (edit)
Description Enrico Scholz 2003-01-17 07:55:27 EST
Description of problem:

While burning, 'cdrecord' shows information about the SCSI commands which
disturbs e.g. the progressmeter:

------
# cdrecord -dev=0,5,0 -speed=4 -dummy foo.img
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
scsidev: '0,5,0'
scsibus: 0 target: 5 lun: 0
Linux sg driver version: 3.1.24
Cannot map "(NULL POINTER)" to a CDROM device.
Cannot map "(NULL POINTER)" to a CDROM device.
Using libscg version 'schily-0.7'
Device type    : Removable CD-ROM
Version        : 2
Response Format: 2
Capabilities   : RELADR SYNC LINKED 
Vendor_info    : 'TEAC    '
Identifikation : 'CD-R55S         '
Revision       : '1.0R'
Device seems to be: Teac CD-R50S.
Using driver for Teac CD-R50S, Teac CD-R55S, JVC XR-W2010, Pinnacle RCD-5020
(teac_cdr50).
Driver flags   : SWABAUDIO 
Supported modes: TAO
Starting to write CD/DVD at speed 4 in dummy TAO mode for single session.
Last chance to quit, starting dummy write    0 seconds. Operation starts.
WRa Data 40 0A 00 00
Buffer cap: 655360
WRa Data 91 0A 00 00
Buffer cap: 655360
Track 01:    0 of  687 MB written.WRa Data 40 0A 00 00
Track 01:    1 of  687 MB written (fifo 100%)Buffer cap: 655360
 [buf 100%]   4.6x.WRa Data 40 0A 00 00
Track 01:    2 of  687 MB written (fifo 100%)Buffer cap: 655360
 [buf 100%]   4.1x.WRa Data 40 0A 00 00
Track 01:    3 of  687 MB written (fifo 100%)Buffer cap: 655360
 [buf 100%]   4.2x.WRa Data 40 0A 00 00
Track 01:    4 of  687 MB written (fifo 100%)Buffer cap: 655360
 [buf 100%]   4.1x.WRa Data 40 0A 00 00
-------

(Remark the 'Buffer cap:' and 'WRa Data' output; in former versions, the
progress was shown in the same line without this information).

Remark the 'Cannot map "(NULL POINTER)" to a CDROM device.' lines too; they are
triggering bug #82054.


Because of patches in the SCSI part (cdrtools-2.0-O_EXCL.patch) I have not
reported it upstream.



Version-Release number of selected component (if applicable):

cdrecord-2.0-2
Comment 1 Harald Hoyer 2003-01-30 07:22:56 EST
"While burning, 'cdrecord' shows information about the SCSI commands which
disturbs e.g. the progressmeter"
This bug is not introduced by RH... should be fixed in xcdroast or reported
upstream...
Comment 2 Enrico Scholz 2004-09-21 19:02:09 EDT
Created attachment 104097 [details]
Disables unwanted debug-output

Please add this (trivial) patch. It was reported upstream to Joerg Schilling
but there is a slow response and I do not know when it will be fixed.
Comment 3 Harald Hoyer 2004-09-22 04:25:28 EDT
Thanks! Will apply!

Note You need to log in before you can comment on or make changes to this bug.