Bug 820932 - [RHEVM] [GUI] [webadmin] VM network check-box should be disabled on network which is attached to cluster
[RHEVM] [GUI] [webadmin] VM network check-box should be disabled on network w...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: vszocs
Martin Pavlik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 07:14 EDT by Martin Pavlik
Modified: 2016-02-10 14:53 EST (History)
8 users (show)

See Also:
Fixed In Version: SI6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:05:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (131.25 KB, image/png)
2012-05-11 07:17 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-05-11 07:14:19 EDT
Description of problem:
VM network check-box is active for networks which are attached to cluster, it is possible to check/uncheck the box but the change is ignored by webadmin, check-box should be grayed out disabled for network which is attached to cluster

Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-9.el6ev 

How reproducible:
100%

Steps to Reproduce:
1) Data Center -> Logical Networks -> New
   a) fill in Name 
   b) check your cluster under Assign Networks to Cluster(s)

2) Data Center -> Logical Networks -> network created in step 1 -> edit
 
  
Actual results:
check-box is active for network which is attached to cluster, but it does not matter whether you change it or not, it remains in same state as before the change

Expected results:
check-box should be grayed out disabled for network which is attached to cluster

Additional info:
Comment 1 Martin Pavlik 2012-05-11 07:17:05 EDT
Created attachment 583805 [details]
screenshot
Comment 2 Avi Tal 2012-05-12 02:26:13 EDT
Actually i believe that the problem is that it is NOT possible to edit VM network after attaching to cluster.

VM network means bridgless/bridged configuration on the host. until it physically configured on host, i see no reason why not being able to edit this check box.
Comment 3 lpeer 2012-05-18 03:15:43 EDT
(In reply to comment #2)
> Actually i believe that the problem is that it is NOT possible to edit VM
> network after attaching to cluster.
> 
> VM network means bridgless/bridged configuration on the host. until it
> physically configured on host, i see no reason why not being able to edit this
> check box.

Your approach is probably the long term solution but currently enabling the edit of a network which is attached to cluster is a bug.
Comment 4 vszocs 2012-05-23 11:18:33 EDT
This issue was also reported upstream, see [https://bugzilla.redhat.com/821021].

Patch [http://gerrit.ovirt.org/4343] was merged upstream, Git commit hash [aa12d1426c2599e12e055df3042a94c56d9d62e8].

Note You need to log in before you can comment on or make changes to this bug.