Bug 820973 - Help -> Content function is broken
Help -> Content function is broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 09:15 EDT by Petr Schindler
Modified: 2013-01-19 19:15 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-19 19:15:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2012-05-11 09:15:55 EDT
Description of problem:
When I press F1 (or Help -> Content) firefox is opened but the page with help is not found.

Version-Release number of selected component (if applicable):
transmission-gtk-2.50-2.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1. run transmitssion
2. press f1
3.
  
Actual results:
Help isn't shown

Expected results:
Help is shown

Additional info:
Because simple-scan is installed by default (when installing from DVD), I
propose this bug as final blocker per criterion:
 "Menu sanity - the following criteria refer to both a live image and default
installed system, and to all release-blocking desktops: "
 - All applications listed under the Applications menu or category must
withstand a basic functionality test and not crash after a few minutes of
normal use. They must also have working Help and Help -> About menu items
Comment 1 Adam Williamson 2012-05-11 21:25:16 EDT
Discussed at 2012-05-11 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-05-11/f17-final-blocker-review-meeting-5.2012-05-11-17.04.html . Accepted as a blocker per criterion cited above.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Tom "spot" Callaway 2012-05-12 15:59:21 EDT
I'm not sure there is anything we can do here, this isn't a bug in the transmission-gtk app, the URL is a 404 because upstream hasn't generated help files for the gtk client since the 2.3x series (see: http://www.transmissionbt.com/help/gtk/ ).

Technically, the items work, and if upstream were to add documentation at the appropriate subdir for 2.5x, the Help->Content would immediately function without need for a package update.

I'd ask that we reconsider this as a NTH but not a blocker.
Comment 3 Tim Flink 2012-05-14 14:58:12 EDT
Discussed during the 2012-05-14 mini blocker review. With the new information from c#2, transmission is working as intended but the issue is a delay in documentation from upstream.

As the software is working as intended, this is no longer considered a blocker for Fedora 17 final.

Note You need to log in before you can comment on or make changes to this bug.