Bug 820993 - javapackages-tools conflicts with jpackage-utils
javapackages-tools conflicts with jpackage-utils
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: javapackages-tools (Show other bugs)
17
Unspecified Linux
high Severity high
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 10:00 EDT by Krzysztof Daniel
Modified: 2014-01-12 19:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 05:32:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Daniel 2012-05-11 10:00:12 EDT
I was playing around with javapackages-tools, build it locally and tried to install. I got:

    Transaction Check Error:
    file /etc/rpm/macros.fjava from install of javapackages-tools-0.3.1-2.fc17.noarch conflicts with file from package jpackage-utils-0:1.7.5-18.fc17.x86_64
    file /usr/lib/rpm/fileattrs/maven.attr from install of javapackages-tools-0.3.1-2.fc17.noarch conflicts with file from package jpackage-utils-0:1.7.5-18.fc17.x86_64
    file /usr/lib/rpm/fileattrs/osgi.attr from install of javapackages-tools-0.3.1-2.fc17.noarch conflicts with file from package jpackage-utils-0:1.7.5-18.fc17.x86_64
    file /usr/lib/rpm/osgi.req from install of javapackages-tools-0.3.1-2.fc17.noarch conflicts with file from package jpackage-utils-0:1.7.5-18.fc17.x86_64
    file /usr/share/java-utils/maven_depmap.py from install of javapackages-tools-0.3.1-2.fc17.noarch conflicts with file from package jpackage-utils-0:1.7.5-18.fc17.x86_64
    file /usr/share/java-utils/maven_depmap.pyc from install of javapackages-tools-0.3.1-2.fc17.noarch conflicts with file from package jpackage-utils-0:1.7.5-18.fc17.x86_64
    file /usr/share/java-utils/maven_depmap.pyo from install of javapackages-tools-0.3.1-2.fc17.noarch conflicts with file from package jpackage-utils-0:1.7.5-18.fc17.x86_64


It does not look like I caused it.
Comment 1 Stanislav Ochotnicky 2012-05-14 05:32:58 EDT
There is no javapackages-tools in F17, nor is there any F17 build: http://koji.fedoraproject.org/koji/packageinfo?packageID=13314

If there was, there would be those conflicts. As it is you probably installed your local build. Either install jpackage-utils from rawhide or stop trying to use rawhide javapackages-tools :-)

Note You need to log in before you can comment on or make changes to this bug.