Bug 821020 - Anaconda dvd install run from usb fails to use usb as install source (insists on networking)
Anaconda dvd install run from usb fails to use usb as install source (insists...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 11:22 EDT by Jonas Thiem
Modified: 2012-05-23 10:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-23 10:34:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonas Thiem 2012-05-11 11:22:50 EDT
Description of problem:
Due to https://bugzilla.redhat.com/show_bug.cgi?id=797455 I cannot use the live cd, so I went for the install dvd. However, liveusb-creator which seems to be recommended in the wiki, doesn't work with the dvd, so I used dd to copy it onto the usb stick.

The installer boots, however it insists on using networking and won't use the usb stick as install source (which contains the entire dvd contents). This makes install without a working network connection impossible for me, and networking actually does fail which I cannot easily solve due to https://bugzilla.redhat.com/show_bug.cgi?id=821014.

Basically all methods I tried failed at some point (livecd: broken with dracut prompt. dvd with liveusb-creator: doesn't boot, dvd with unetbootin: doesn't boot either, dvd with dd: boots but insists on networking, networking: fails with dubious error) and I bet every average user would have given up installing it by now.

Version-Release number of selected component (if applicable):
TC4 F17 anaconda

How reproducible:
100% for me

Steps to Reproduce:
1. dd dvd image to usb stick
2. boot from usb stick and do partitioning (I formatted from scratch and also used a boot sector if that helps, also I tried the "askmethod" option since folks in #fedora suggested that)
3. installer will always ask for networking as soon as it asked for boot sector info ("[X] Install boot loader on XXX. [Change device], [ ] Use a boot loader password [Change password]"). 
  
Actual results:
networking is required

Expected results:
networking is not required

Additional info:
Comment 1 Jonas Thiem 2012-05-11 12:00:17 EDT
I was suggested to use "livecd-iso-to-disk --format --reset-mbr Fedora-17-TC4-x86_64-DVD.iso /dev/sdb1" which resolves the issue. Maybe that helps in narrowing down the problem.
Comment 2 Jonas Thiem 2012-05-11 13:01:44 EDT
I just rechecked after a remark this was fixed in alpha. It seems I accidentially used the DVD beta image and not TC4 (as specified above), so the bug might already be fixed. Sorry for the version mixup

Note You need to log in before you can comment on or make changes to this bug.