Bug 821041 - packagegroup install of custom groups seems to be failing
packagegroup install of custom groups seems to be failing
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Matthews
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 11:46 EDT by Preethi Thomas
Modified: 2012-05-25 10:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-25 10:13:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-05-11 11:46:18 EDT
Description of problem:

Custom packagegroup install on consumer seems to be failing

Version-Release number of selected component (if applicable):
 

How reproducible:

[root@pulp-v1-server ~]# rpm -q pulp
pulp-1.1.8-1.el6.noarch

Steps to Reproduce:
1. Create a custom package group in a repo 
2. Add packages in the repo to the group
3. Bind the consumer to the repo
4. Attempt to install the custom pakagegroup

I have  a packagegroup "test" that I create in repo rhel_2

[root@pulp-v1-server ~]# pulp-admin packagegroup add_package --id test --repoid rhel6_2 -n yajl --type mandatory
Following packages added to group [test] in repository [rhel6_2]: 
 ['yajl']


[root@pulp-v1-server ~]# pulp-admin packagegroup add_package --id test --repoid rhel6_2 -n emacs --type optional

[root@pulp-v1-server ~]# pulp-admin packagegroup info --repoid rhel6_2 --id test
+------------------------------------------+
          Package Group Information
+------------------------------------------+

Name                	test                     
Id                  	test                     
Mandatory packages  	[u'yajl']                
Default packages    	[u'zsh']                 
Optional packages   	[u'emacs', u'emacs-common']
Conditional packages	{}        

[root@pulp-v1-server ~]# pulp-admin -u admin -p admin packagegroup list --repoid rhel6_2 |grep test
	 test
	 test1


[root@pulp-v1-server ~]# pulp-admin -u admin -p admin packagegroup install --consumerid pulp-client --id test
Created task id: 42313d38-9b7d-11e1-9a1c-52540067ae07
Waiting: [\] 
Consumer ID: pulp-client  [ FAILED ] No Group named test exists


On a package that is existing in the repo
[root@pulp-v1-server ~]# pulp-admin -u admin -p admin packagegroup install --consumerid pulp-client --id postgresql
Created task id: 99455f1e-9b7d-11e1-94ca-52540067ae07
Waiting: [\] 
Consumer ID: pulp-client  [ SUCCEEDED ]
=====================================================================
Package                           Arch     Version    Repository
=====================================================================
Installed:
postgresql-docs                   x86_64   8.4.9      rhel6_2
postgresql-server                 x86_64   8.4.9      rhel6_2

Installed for dependencies:
postgresql                        x86_64   8.4.9      rhel6_2
postgresql-libs                   x86_64   8.4.9      rhel6_2

  
Actual results:
[root@pulp-v1-server ~]# pulp-admin -u admin -p admin packagegroup install --consumerid pulp-client --id test
Created task id: 42313d38-9b7d-11e1-9a1c-52540067ae07
Waiting: [\] 
Consumer ID: pulp-client  [ FAILED ] No Group named test exists



Expected results:


Additional info:
Comment 1 John Matthews 2012-05-21 16:35:57 EDT
The problem was that we assumed a checksum type of sha256 would always be used for repomd.xml when referring to groups/groups_gz.  The repo identified in comment #0, rhel_62, had existing groups data using a checksum type of 'sha'.  

When Pulp updated repomd.xml with new data it used sha256 checksum without updating the checksum_type to reflect sha256.
So...we had 'sha256' checksum value yet the checksum type was 'sha'.  This led to the client reporting an error and not being able to parse the groups data.

To minimize changes for pulp_v1 we have decided to use the common denominator of 'sha' for groups/groups_gz checksum in repomd.xml.

The below commit addresses this problem.

http://git.fedorahosted.org/git/?p=pulp.git;a=commitdiff;h=c8726ec52ff1e272bc8aa96420c4dbec49cdd12e
Comment 2 Jeff Ortel 2012-05-22 09:18:03 EDT
build: 1.1.10
Comment 3 Preethi Thomas 2012-05-22 13:58:46 EDT
[root@pulp-v1-server ~]# pulp-admin -u admin -p admin packagegroup create --id preethi --repoid rhel6_2  --name preethi
Package group [preethi] created in repository [rhel6_2]

[root@pulp-v1-server ~]# pulp-admin -u admin -p admin packagegroup add_package --repoid rhel6_2 --name zsh --id preethi
Following packages added to group [preethi] in repository [rhel6_2]: 
 ['zsh']

[root@pulp-v1-server ~]# pulp-admin -u admin -p admin packagegroup add_package --repoid rhel6_2 --name yajl --id preethi
Following packages added to group [preethi] in repository [rhel6_2]: 
 ['yajl']

[root@pulp-v1-server ~]# pulp-admin -u admin -p admin packagegroup install --consumerid pulp-client --id preethi
Created task id: a24f52b3-a434-11e1-a4ea-52540067ae07
Waiting: [\] 
Consumer ID: pulp-client  [ SUCCEEDED ]
=====================================================================
Package                           Arch     Version    Repository
=====================================================================
Installed:
yajl                              x86_64   1.0.7      rhel6_2
zsh                               x86_64   4.3.10     rhel6_2


[root@pulp-v1-server ~]# pulp-admin -u admin -p admin packagegroup install --id network-tools --consumerid pulp-client
Created task id: a7514f9e-a437-11e1-aee6-52540067ae07
Waiting: [\] 
Consumer ID: pulp-client  [ SUCCEEDED ]
=====================================================================
Package                           Arch     Version    Repository
=====================================================================
Installed:
nc                                x86_64   1.84       rhel6_2
openswan                          x86_64   2.6.32     rhel6_2

[root@pulp-v1-server ~]#
Comment 4 Preethi Thomas 2012-05-25 10:13:16 EDT
Pulp v1.1 Release

Note You need to log in before you can comment on or make changes to this bug.