This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 821054 - Red Hat certification tests fail to run on RHEL 7.0 alpha
Red Hat certification tests fail to run on RHEL 7.0 alpha
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (distribution) (Show other bugs)
6.1
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 13:22 EDT by Seth Bidleman
Modified: 2013-02-01 13:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 13:20:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Seth Bidleman 2012-05-11 13:22:36 EDT
Description of problem:
The latest Red Hat certification tests (v7-1.5-18.el6.noarch.rpm) fail to run with the following message:

Traceback (most recent call last):
  File "/usr/bin/v7", line 31, in <module>
    v7=HardwareTestHarness()
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 67, in __init__
    self.redHatRelease = RedHatRelease()
  File "/usr/share/v7/lib/v7/redhatrelease.py", line 36, in __init__
    self.__getKernelInfo()
  File "/usr/share/v7/lib/v7/redhatrelease.py", line 85, in __getKernelInfo
    self.parseUnameOutput(unameOutput)
  File "/usr/share/v7/lib/v7/redhatrelease.py", line 91, in parseUnameOutput
    if "Red Hat" in self.getProduct() and self.getVersion() == 4:
TypeError: argument of type 'NoneType' is not iterable

This error is likely due to the certification tests do not support RHEL 7.0 yet.
Comment 6 errata-xmlrpc 2013-02-01 13:20:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0222.html

Note You need to log in before you can comment on or make changes to this bug.