Bug 821076 - Claws mail patch for e-mail attachment handling needs applied
Claws mail patch for e-mail attachment handling needs applied
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: claws-mail (Show other bugs)
16
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 15:02 EDT by Kevin T. Likes
Modified: 2012-11-20 08:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-20 08:54:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin T. Likes 2012-05-11 15:02:22 EDT
Description of problem:

Claws-Mail handles e-mail attachments inconsistently. 

Version-Release number of selected component (if applicable):

3.8.0

How reproducible:

See Claws-Mail ticket #2659

Steps to Reproduce:

See above ticket.
  
Actual results:

See above ticket.

Expected results:

See above ticket.

Additional info:

There is a patch on that bug-id that fixes the issue.
Comment 1 Michael Schwendt 2012-05-11 15:29:05 EDT
As you can see at
  http://www.claws-mail.org/tracker/index.php?len=90
there are many other post-3.8.0 commits. The commit 3.8.0cvs40 for the bug you refer to is just one out of many.

Where to start, where to end? While cherry-picking upstream post-release commits can be beneficial in some cases, what would make this patch more important than other post-3.8.0 fixes? Some of those patches can be applied to the 3.8.0 version we ship. Others need backporting or would depend on additional patches. Using a snapshot isn't too safe either. Further, this particular patch needs testing.

Eventually, there will be a 3.8.1 release. 3.8.0 is from December 2011.
Comment 2 Kevin T. Likes 2012-05-11 17:15:10 EDT
The suggestion to open the bug was made by the Claws-mail developers, to see if yo wanted to put it in. Their indication was that the next release isn't even planned. I had seen Claws-Mail affected by updates, though I didn't know if they were to Claws itself or other packages it relies on.

One thing this bugfix does provide is a major (though short) fix to the handling of nested mime-encoded attachments. I can't say that that affects a lot of people, but it was causing major glitches in my workflow.

I am willing to test the patch if you can give me an updated package. Or if you want to wait on this until release, I can always build myself a local copy of the program. In the latter case, you can close the ticket.
Comment 3 Michael Schwendt 2012-05-13 09:05:31 EDT
> The suggestion to open the bug was made by the Claws-mail developers,
> to see if yo wanted to put it in.

Where can this suggestion be found?


> I had seen Claws-Mail affected by updates, though I didn't know if
> they were to Claws itself or other packages it relies on.

Why haven't you filed a bug report nevertheless?

For Fedora 16 and 15 we've had bug-fix collection updates for Claws Mail 3.7.10,
  https://admin.fedoraproject.org/updates/FEDORA-2011-17063
as well as the larger upgrade to 3.8.0,
  https://admin.fedoraproject.org/updates/FEDORA-2011-17584
but no other updates since then.


Anyway, the questions raised in comment 1 are just my personal point of view.
Comment 4 Kevin T. Likes 2012-05-15 22:07:03 EDT
The suggestion was in an email conversation with the claws mail developer who closed their ticket.

I'm not sure what the second question is asking. There was a claws mail ticket (now closed) and this one.
Comment 5 Michael Schwendt 2012-07-07 09:59:15 EDT
https://admin.fedoraproject.org/updates/FEDORA-2012-10349

Note You need to log in before you can comment on or make changes to this bug.