Bug 821078 - RFE: Provide ability to retrieve errata applicable to consumer group or set of consumers
RFE: Provide ability to retrieve errata applicable to consumer group or set o...
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: Triaged
: 824058 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 15:09 EDT by Brad Buckingham
Modified: 2014-11-18 09:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
RFE
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 09:01:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Buckingham 2012-05-11 15:09:31 EDT
Description of problem:

For Katello, we plan to support system (consumer) groups.  As part of that feature, we'd like to be able to go to a group (in katello), observe the list of errata that are applicable to the consumers in that group, select 1 or more of the errata and initiate an install.

In order to do this efficiently, we'd like to get a couple of additional APIs in to pulp, including:

1. Given a list of consumer ids, retrieve the list of errata that are applicable (i.e. that need to be installed) on 1 or more of the consumers in the list.  For each errata returned, include the list of consumer IDs that the errata applies to.

2. Given a consumer group id, retrieve the list of errata that are applicable (i.e. that need to be installed) on 1 or more of the consumers in the group.  For each errata returned, include the list of consumer IDs that the errata applies to.

2 is a simple variation of 1 and I'd view it as the more important of the APIs, since Katello is using Pulp consumer groups.
Comment 2 Randy Barlow 2014-01-02 16:33:51 EST
We have the first item now, but I don't believe we support applicability for consumer groups yet. Is this still important?
Comment 3 Randy Barlow 2014-01-02 16:36:34 EST
*** Bug 824058 has been marked as a duplicate of this bug. ***
Comment 4 Chris Duryee 2014-11-18 09:01:58 EST
The Katello team confirmed they don't need this anymore. Marking as closed/notabug.

Note You need to log in before you can comment on or make changes to this bug.