This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 821084 - After installing PyYAML 3.10-3 cobbler stops working.
After installing PyYAML 3.10-3 cobbler stops working.
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: PyYAML (Show other bugs)
el5
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: John Eckersberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 16:09 EDT by Edward
Modified: 2012-05-11 16:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-11 16:32:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward 2012-05-11 16:09:44 EDT
Description of problem:ran yum-update on server and PyYaml 3.10-3 was installed which caused cobblerd and cobbler commands/scripts to stop working.

Rolling back to PyYAML 3.08-4 seems to resolve the problem.

Version-Release number of selected component (if applicable):
cobbler 2.2.2-1
cobbler-web 2.2.2-1
PyYAML 3.10-3
CentOS 5.8

How reproducible:

Steps to Reproduce:
1. On a system running cobbler 2.2.1-x upgrade cobbler and cobbler-web only to 2.2.2-1.
2.verify that cobblerd and cobbler commands still work along with cobbler-web.
3.upgrade PyYAML from 3.08 to 3.10-3.
4.restart cobblerd and try to run cobbler.  You should see the errors above.
  
Actual results:
# /etc/init.d/cobblerd start
Starting cobbler daemon: Traceback (most recent call last):
  File "/usr/bin/cobblerd", line 19, in ?
    import cobbler.cobblerd as app
  File "/usr/lib/python2.4/site-packages/cobbler/cobblerd.py", line 29, in ?
    from utils import _
  File "/usr/lib/python2.4/site-packages/cobbler/utils.py", line 49, in ?
    import yaml
  File "/usr/lib64/python2.4/site-packages/yaml/__init__.py", line 26
    yield loader.get_token()
SyntaxError: 'yield' not allowed in a 'try' block with a 'finally' clause
                                                           [FAILED]
/etc/init.d/cobblerd start
Starting cobbler daemon: Traceback (most recent call last):
  File "/usr/bin/cobblerd", line 19, in ?
    import cobbler.cobblerd as app
  File "/usr/lib/python2.4/site-packages/cobbler/cobblerd.py", line 29, in ?
    from utils import _
  File "/usr/lib/python2.4/site-packages/cobbler/utils.py", line 49, in ?
    import yaml
  File "/usr/lib64/python2.4/site-packages/yaml/__init__.py", line 26
    yield loader.get_token()
SyntaxError: 'yield' not allowed in a 'try' block with a 'finally' clause
                                                           [FAILED]

Expected results:

# service cobblerd start
Starting cobbler daemon:                                   [  OK  ]


# cobbler
usage
=====
cobbler <distro|profile|system|repo|image|mgmtclass|package|file> ... 
        [add|edit|copy|getks*|list|remove|rename|report] [options|--help]
cobbler <aclsetup|buildiso|import|list|replicate|report|reposync|sync|validateks|version> [options|--help]

Additional info:
Comment 1 John Eckersberg 2012-05-11 16:32:14 EDT
PyYAML 3.10 dropped support for Python 2.4, so I've unpushed this build from updates-testing.  Here's the removal in bodhi - https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-5717/PyYAML-3.10-3.el5

To be clear, this build never was pushed to stable for EPEL5, only to testing.  I'm going to close this as NOTABUG, only because I don't know what else to label it as, since it never made it out of testing.

Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.